summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..67410d6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ \
+ --buildsystem=cmake \
+ --parallel \
+ --dbg-package=colobot-dbg
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DCMAKE_BUILD_TYPE:STRING="RelWithDebInfo" \
+ -DINSTALL_DOCS:BOOL=True \
+ -DOPENAL_SOUND:BOOL=True
+
+override_dh_auto_build:
+ dh_auto_build -a
+ dh_auto_build -i -- doc
+ # obj-* is the default builddirectory in debhelper
+ convert obj-$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)/desktop/32/colobot.png debian/colobot.xpm
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f debian/colobot.xpm