summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..2bd7461
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.8)
+
+set(_potFile colobot.pot)
+
+find_program(XGETTEXT_CMD xgettext)
+
+add_custom_command(OUTPUT ${_potFile}
+ COMMAND ${XGETTEXT_CMD} ${colobot_SOURCE_DIR}/src/app/app.cpp --output=${_potFile}
+ COMMAND ${XGETTEXT_CMD} ${colobot_SOURCE_DIR}/src/common/restext.cpp --output=${_potFile} --join-existing --extract-all --no-location
+
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMENT "Extract translatable messages to ${_potFile}"
+)
+
+add_custom_target(update-pot DEPENDS ${_potFile})
+
+file(GLOB _poFiles *.po)
+set(GETTEXT_INSTALL_PREFIX ${COLOBOT_INSTALL_I18N_DIR})
+gettext_create_translations(${_potFile} ALL ${_poFiles})
+