summaryrefslogtreecommitdiffstats
path: root/src/CBot/tests/CBot_console/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CBot/tests/CBot_console/CMakeLists.txt')
-rw-r--r--src/CBot/tests/CBot_console/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/CBot/tests/CBot_console/CMakeLists.txt b/src/CBot/tests/CBot_console/CMakeLists.txt
new file mode 100644
index 0000000..7d9f034
--- /dev/null
+++ b/src/CBot/tests/CBot_console/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(CBot_console C CXX)
+
+# Build with debugging symbols
+set(CMAKE_BUILD_TYPE debug)
+
+# Global compile flags
+set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -Wold-style-cast -std=gnu++0x")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
+
+# Include cmake directory
+SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${colobot_SOURCE_DIR}/cmake")
+
+add_subdirectory(src bin)