summaryrefslogtreecommitdiffstats
path: root/src/CBot/tests/CBot_console/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CBot/tests/CBot_console/src/CMakeLists.txt')
-rw-r--r--src/CBot/tests/CBot_console/src/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/CBot/tests/CBot_console/src/CMakeLists.txt b/src/CBot/tests/CBot_console/src/CMakeLists.txt
new file mode 100644
index 0000000..3dbf711
--- /dev/null
+++ b/src/CBot/tests/CBot_console/src/CMakeLists.txt
@@ -0,0 +1,32 @@
+# CBot shared library is built separately
+add_subdirectory(CBot)
+
+
+# Configure options
+option(DEBUG "Enable debug output" ON)
+
+set(PLATFORM_LIBS "")
+
+# Source files
+# Commented out files are still dependent on DirectX or WinAPI
+
+set(SOURCES
+app/CClass.cpp
+app/main.cpp
+#app/routines.cpp
+app/CBotDoc.cpp
+app/CBotConsole.cpp
+)
+
+set(LIBS
+CBot
+)
+
+include_directories(. ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+link_directories(${CMAKE_CURRENT_SOURCE_DIR}/CBot)
+
+add_executable(CBot_console ${SOURCES})
+
+target_link_libraries(CBot_console ${LIBS})