summaryrefslogtreecommitdiffstats
path: root/src/CBot
diff options
context:
space:
mode:
Diffstat (limited to 'src/CBot')
-rw-r--r--src/CBot/CBotVar.cpp2
-rw-r--r--src/CBot/CMakeLists.txt6
2 files changed, 6 insertions, 2 deletions
diff --git a/src/CBot/CBotVar.cpp b/src/CBot/CBotVar.cpp
index 2430d0d..7b0ce7b 100644
--- a/src/CBot/CBotVar.cpp
+++ b/src/CBot/CBotVar.cpp
@@ -590,7 +590,7 @@ void CBotVar::AddNext(CBotVar* pVar)
void CBotVar::SetVal(CBotVar* var)
{
- switch (/*var->*/GetType())
+ switch (var->GetType())
{
case CBotTypBoolean:
SetValInt(var->GetValInt());
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index 409ef3b..9f5b987 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -12,4 +12,8 @@ CBotVar.cpp
CBotWhile.cpp
)
-add_library(CBot SHARED ${SOURCES})
+if(${CBOT_STATIC})
+ add_library(CBot STATIC ${SOURCES})
+else()
+ add_library(CBot SHARED ${SOURCES})
+endif()