summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 12171f3..e02a30b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -61,7 +61,6 @@ endif()
# Source files
set(SOURCES
app/app.cpp
-app/gamedata.cpp
app/main.cpp
app/pausemanager.cpp
app/system.cpp
@@ -75,6 +74,12 @@ common/misc.cpp
common/profile.cpp
common/restext.cpp
common/stringutils.cpp
+common/resources/resourcemanager.cpp
+common/resources/inputstreambuffer.cpp
+common/resources/outputstreambuffer.cpp
+common/resources/inputstream.cpp
+common/resources/outputstream.cpp
+common/resources/sndfile.cpp
graphics/core/color.cpp
graphics/engine/camera.cpp
graphics/engine/cloud.cpp
@@ -202,6 +207,7 @@ ${Boost_LIBRARIES}
${LIBSNDFILE_LIBRARY}
${OPTIONAL_LIBS}
${PLATFORM_LIBS}
+${PHYSFS_LIBRARY}
)
# Local
@@ -224,6 +230,7 @@ ${LIBSNDFILE_INCLUDE_DIR}
${LOCALENAME_INCLUDE_DIR}
${OPTIONAL_INCLUDE_DIRS}
${CLIPBOARD_INCLUDE_DIR}
+${PHYSFS_INCLUDE_PATH}
)
link_directories(${CMAKE_CURRENT_SOURCE_DIR}/CBot)