summaryrefslogtreecommitdiffstats
path: root/src/math/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/math/test/CMakeLists.txt')
-rw-r--r--src/math/test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/math/test/CMakeLists.txt b/src/math/test/CMakeLists.txt
index af9bcca..3d52dd9 100644
--- a/src/math/test/CMakeLists.txt
+++ b/src/math/test/CMakeLists.txt
@@ -5,11 +5,13 @@ set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0")
add_executable(matrix_test matrix_test.cpp)
add_executable(vector_test vector_test.cpp)
+add_executable(geometry_test geometry_test.cpp)
enable_testing()
add_test(matrix_test ./matrix_test)
add_test(vector_test ./vector_test)
+add_test(geometry_test ./geometry_test)
# 'make check' will compile the required test programs
# Note that 'make test' will still fail without compiled programs
@@ -20,6 +22,7 @@ set(REMOVE_FILES
CMakeFiles Testing cmake_install.cmake CMakeCache.txt CTestTestfile.cmake Makefile
./matrix_test
./vector_test
+ ./geometry_test
)
-add_custom_target(distclean COMMAND rm -rf ${REMOVE_FILES}) \ No newline at end of file
+add_custom_target(distclean COMMAND rm -rf ${REMOVE_FILES})