summaryrefslogtreecommitdiffstats
path: root/src/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/po/CMakeLists.txt')
-rw-r--r--src/po/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/po/CMakeLists.txt b/src/po/CMakeLists.txt
index 3b26571..df667dd 100644
--- a/src/po/CMakeLists.txt
+++ b/src/po/CMakeLists.txt
@@ -6,14 +6,13 @@ find_program(XGETTEXT_CMD xgettext)
add_custom_command(OUTPUT ${_potFile}
COMMAND ${XGETTEXT_CMD} ../app/app.cpp --output=${_potFile}
- COMMAND ${XGETTEXT_CMD} ../common/restext_strings.c --output=${_potFile} --join-existing --extract-all --no-location
+ COMMAND ${XGETTEXT_CMD} ../common/restext.cpp --output=${_potFile} --join-existing --extract-all --no-location
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Extract translatable messages to ${_potFile}"
)
-add_custom_target(_${potFile} ${_all} DEPENDS ${_potFile})
+add_custom_target(update-pot DEPENDS ${_potFile})
file(GLOB _poFiles *.po)
-
gettext_create_translations(${_potFile} ALL ${_poFiles})