summaryrefslogtreecommitdiffstats
path: root/src/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/po/CMakeLists.txt')
-rw-r--r--src/po/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/po/CMakeLists.txt b/src/po/CMakeLists.txt
new file mode 100644
index 0000000..df667dd
--- /dev/null
+++ b/src/po/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 2.8)
+
+set(_potFile colobot.pot)
+
+find_program(XGETTEXT_CMD xgettext)
+
+add_custom_command(OUTPUT ${_potFile}
+ COMMAND ${XGETTEXT_CMD} ../app/app.cpp --output=${_potFile}
+ COMMAND ${XGETTEXT_CMD} ../common/restext.cpp --output=${_potFile} --join-existing --extract-all --no-location
+
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMENT "Extract translatable messages to ${_potFile}"
+)
+
+add_custom_target(update-pot DEPENDS ${_potFile})
+
+file(GLOB _poFiles *.po)
+gettext_create_translations(${_potFile} ALL ${_poFiles})