summaryrefslogtreecommitdiffstats
path: root/src/sound/oalsound/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/sound/oalsound/CMakeLists.txt')
-rw-r--r--src/sound/oalsound/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/src/sound/oalsound/CMakeLists.txt b/src/sound/oalsound/CMakeLists.txt
deleted file mode 100644
index bb7e9ff..0000000
--- a/src/sound/oalsound/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-cmake_minimum_required(VERSION 2.8)
-
-set(SOURCES
- alsound.cpp
- buffer.cpp
- channel.cpp
-)
-
-SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++0x -fPIC")
-SET (CMAKE_CXX_FLAGS_DEBUG "-g")
-
-include(FindPkgConfig)
-include(FindOpenAL)
-pkg_check_modules(OPENAL_LIB REQUIRED openal)
-
-set(OPENAL_LIBRARIES
- openal
- alut
-)
-
-include_directories(../../..)
-include_directories(.)
-add_library(openalsound SHARED ${SOURCES})
-target_link_libraries(openalsound ${OPENAL_LIBRARIES})