summaryrefslogtreecommitdiffstats
path: root/src/sound/plugins/oalsound/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/sound/plugins/oalsound/test/CMakeLists.txt')
-rw-r--r--src/sound/plugins/oalsound/test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/sound/plugins/oalsound/test/CMakeLists.txt b/src/sound/plugins/oalsound/test/CMakeLists.txt
index f7b165c..27ab756 100644
--- a/src/sound/plugins/oalsound/test/CMakeLists.txt
+++ b/src/sound/plugins/oalsound/test/CMakeLists.txt
@@ -1,6 +1,8 @@
cmake_minimum_required(VERSION 2.8)
-set(CMAKE_BUILD_TYPE debug)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11 -rdynamic")
add_executable(plugin_test plugin_test.cpp ../../../../common/iman.cpp ../../../../common/logger.cpp ../../../../plugins/pluginloader.cpp)