summaryrefslogtreecommitdiffstats
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/plugins/test/CMakeLists.txt2
-rw-r--r--src/sound/plugins/oalsound/test/CMakeLists.txt2
3 files changed, 3 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f59abbc..f68a1d5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -173,7 +173,7 @@ ${PNG_LIBRARIES}
${OPTIONAL_LIBS}
${PLATFORM_LIBS}
${Boost_LIBRARIES}
-ltdl
+${LTDL_LIBRARY}
CBot
)
diff --git a/src/plugins/test/CMakeLists.txt b/src/plugins/test/CMakeLists.txt
index 5f86b6f..a68de2c 100644
--- a/src/plugins/test/CMakeLists.txt
+++ b/src/plugins/test/CMakeLists.txt
@@ -9,4 +9,4 @@ include_directories(".")
include_directories("../../")
include_directories("../../../")
-target_link_libraries(manager_test ltdl)
+target_link_libraries(manager_test ${LTDL_LIBRARY})
diff --git a/src/sound/plugins/oalsound/test/CMakeLists.txt b/src/sound/plugins/oalsound/test/CMakeLists.txt
index d10169b..f7b165c 100644
--- a/src/sound/plugins/oalsound/test/CMakeLists.txt
+++ b/src/sound/plugins/oalsound/test/CMakeLists.txt
@@ -8,4 +8,4 @@ add_executable(plugin_test plugin_test.cpp ../../../../common/iman.cpp ../../../
include_directories(".")
include_directories("../../../../")
-target_link_libraries(plugin_test ltdl)
+target_link_libraries(plugin_test ${LTDL_LIBRARY})