summaryrefslogtreecommitdiffstats
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/CBot/CMakeLists.txt2
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/graphics/core/device.h2
3 files changed, 5 insertions, 1 deletions
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index 9f5b987..271f2ce 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -17,3 +17,5 @@ if(${CBOT_STATIC})
else()
add_library(CBot SHARED ${SOURCES})
endif()
+
+INSTALL_TARGETS(/lib CBot)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a7f1c96..c8372b0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -192,3 +192,5 @@ link_directories(${CMAKE_CURRENT_SOURCE_DIR}/CBot)
add_executable(colobot ${SOURCES})
target_link_libraries(colobot ${LIBS})
+
+INSTALL_TARGETS(/games colobot)
diff --git a/src/graphics/core/device.h b/src/graphics/core/device.h
index ba5af6e..b6dd138 100644
--- a/src/graphics/core/device.h
+++ b/src/graphics/core/device.h
@@ -72,7 +72,7 @@ struct DeviceConfig
size = Math::IntPoint(800, 600);
bpp = 32;
fullScreen = false;
- resizeable = true;
+ resizeable = false;
doubleBuf = true;
noFrame = false;
}