summaryrefslogtreecommitdiffstats
path: root/test/unit/common
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit/common')
-rw-r--r--test/unit/common/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/test/unit/common/CMakeLists.txt b/test/unit/common/CMakeLists.txt
index aebf17a..cf37961 100644
--- a/test/unit/common/CMakeLists.txt
+++ b/test/unit/common/CMakeLists.txt
@@ -7,10 +7,15 @@ ${GTEST_INCLUDE_DIR}
add_executable(image_test ${SRC_DIR}/common/image.cpp image_test.cpp)
target_link_libraries(image_test ${SDL_LIBRARY} ${SDLIMAGE_LIBRARY} ${PNG_LIBRARIES})
+add_test(NAME image_test
+ COMMAND ${CMAKE_BINARY_DIR}/image_test ${CMAKE_SOURCE_DIR}/test/envs/opengl/tex1.png ${CMAKE_BINARY_DIR}/tex1_test.png)
file(COPY colobot.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
-# add_executable(profile_test ${SRC_DIR}/common/profile.cpp ${SRC_DIR}/common/logger.cpp profile_test.cpp)
-# target_link_libraries(profile_test gtest ${Boost_LIBRARIES})
+add_executable(profile_test ${SRC_DIR}/common/profile.cpp ${SRC_DIR}/common/logger.cpp profile_test.cpp)
+set_target_properties(profile_test PROPERTIES COMPILE_DEFINITIONS "DEV_BUILD=1")
+target_link_libraries(profile_test gtest ${Boost_LIBRARIES})
-# add_test(profile_test ./profile_test)
+add_test(NAME profile_test
+ COMMAND ${CMAKE_BINARY_DIR}/profile_test
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})