summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..53a1a37
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
+
+%:
+ dh $@
+
+override_dh_auto_build:
+
+override_dh_install:
+ cp *.py debian/phenny/usr/share/python-support/phenny/phenny
+ cp modules/*.py debian/phenny/usr/share/python-support/phenny/phenny/modules
+ chmod -R 644 debian/phenny/usr/share/python-support/phenny/phenny/*.py
+ chmod -R 644 debian/phenny/usr/share/python-support/phenny/phenny/modules/*.py
+ cp phenny debian/phenny/usr/bin
+ help2man -N -n "an extensible IRC bot written in Python" --version-string=$(DEBVERS) ./phenny > debian/phenny.1