summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2013-01-24 04:41:56 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2013-01-30 01:42:59 +0100
commit4db68de5892cf836544da2e7dfd71433aeebd1e3 (patch)
tree8970bff256af5dbc3f982fe5514b81251260571d
parent91126230cde39e3be3f07daa945cde9dc24af4fc (diff)
downloadbcfg2-debian/1.2.3-4.tar.gz
bcfg2-debian/1.2.3-4.tar.bz2
bcfg2-debian/1.2.3-4.zip
Client: always actions do not modify hostsdebian/1.2.3-4
Actions that are executed always, does not set the host statistics to modified. (One always action would lead to always modified hosts)
-rw-r--r--debian/changelog6
-rw-r--r--src/lib/Client/Frame.py3
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8863987a8..d06347378 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+bcfg2 (1.2.3-4) unstable; urgency=low
+
+ * Client: always actions do not modify hosts
+
+ -- Alexander Sulfrian <alex@spline.inf.fu-berlin.de> Thu, 24 Jan 2013 04:42:06 +0100
+
bcfg2 (1.2.3-3) unstable; urgency=low
* Client: allow pre-Actions and important-Paths to enable installs
diff --git a/src/lib/Client/Frame.py b/src/lib/Client/Frame.py
index 5826b36e8..78b1dd1d9 100644
--- a/src/lib/Client/Frame.py
+++ b/src/lib/Client/Frame.py
@@ -445,7 +445,8 @@ class Frame:
stats.set('state', 'dirty')
# List bad elements of the configuration
- for (data, ename) in [(self.modified, 'Modified'), (self.extra, "Extra"), \
+ mods = [m for m in self.modified if m.tag != 'Action' or m.get('when') != 'always']
+ for (data, ename) in [(mods, 'Modified'), (self.extra, "Extra"), \
([entry for entry in self.states if not \
self.states[entry]], "Bad")]:
container = Bcfg2.Client.XML.SubElement(stats, ename)