summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorRick Bradshow <bradshaw@mcs.anl.gov>2006-03-06 19:50:18 +0000
committerRick Bradshow <bradshaw@mcs.anl.gov>2006-03-06 19:50:18 +0000
commit63c9efaa630e8e3aace3d1e85de3e8609dfb1bfd (patch)
treeea5e55e80bcd4ac2130cfbef09d70e7acc1b1ecc /debian
parent15460338b8196be16dc6733ba19a3f0f8cf03a0a (diff)
downloadbcfg2-63c9efaa630e8e3aace3d1e85de3e8609dfb1bfd.tar.gz
bcfg2-63c9efaa630e8e3aace3d1e85de3e8609dfb1bfd.tar.bz2
bcfg2-63c9efaa630e8e3aace3d1e85de3e8609dfb1bfd.zip
this is to make the python version binary package builder for debian
packages non static git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@1795 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
-rwxr-xr-xdebian/version-hacker.sh26
2 files changed, 28 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 9ba490a2a..243d64ab8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,8 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
-build:
+build:
+ debian/version-hacker.sh
python setup.py build
clean:
diff --git a/debian/version-hacker.sh b/debian/version-hacker.sh
new file mode 100755
index 000000000..e400cb37f
--- /dev/null
+++ b/debian/version-hacker.sh
@@ -0,0 +1,26 @@
+#!/bin/bash
+
+CWD=`pwd`
+echo $CWD
+
+cd debian/
+
+#get the default python version for this system.
+VERSION=`python -c 'import sys;major,minor = sys.version_info[0:2]; print minor '`
+
+#hardcoded version is 2.3
+
+if [ ${VERSION} -eq 4 ]; then
+
+#fix all the files that are version specific
+
+ for fd in bcfg2.install bcfg2.postinst.debhelper bcfg2-server.install bcfg2-server.posti\nst.debhelper;
+ do
+ sed -e 's/2\.3/2\.4/g' $fd > /tmp/${fd}.tmp
+ mv /tmp/${fd}.tmp $fd
+ #rm /tmp/${fd}.tmp
+ done
+
+fi
+
+cd $CWD