summaryrefslogtreecommitdiffstats
path: root/encap/epkg
diff options
context:
space:
mode:
authorDaniel Joseph Barnhart Clark <dclark@pobox.com>2006-08-02 03:35:56 +0000
committerDaniel Joseph Barnhart Clark <dclark@pobox.com>2006-08-02 03:35:56 +0000
commit26a92c11cc3269498611e778b1849b6aa61b63c2 (patch)
tree8dfaae6683c46ac18eadc3bde24cb1f22e9ee9f5 /encap/epkg
parentc97b23046e161247509c104e74a5d9b73f8701be (diff)
downloadbcfg2-26a92c11cc3269498611e778b1849b6aa61b63c2.tar.gz
bcfg2-26a92c11cc3269498611e778b1849b6aa61b63c2.tar.bz2
bcfg2-26a92c11cc3269498611e778b1849b6aa61b63c2.zip
* reorged tangential tools into tools directory
* added ostiary encap git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@2024 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'encap/epkg')
-rw-r--r--encap/epkg/Makefile43
-rw-r--r--encap/epkg/README23
2 files changed, 0 insertions, 66 deletions
diff --git a/encap/epkg/Makefile b/encap/epkg/Makefile
deleted file mode 100644
index 6f4cf7277..000000000
--- a/encap/epkg/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# $Id$
-
-.PHONY : all clean distclean install zlib libtar openssl curl fget expat epkg
-.SUFFIXES :
-
-BASEDIR = /usr/local
-ENCAPDIR = ${BASEDIR}/encap
-PREFIX = /tmp/epkg-static-libs
-PATH = ${PREFIX}/bin:/usr/sfw/bin:/usr/ccs/bin:/usr/local/bin:/opt/csw/bin:/usr/sbin:/usr/bin
-LDFLAGS = -L${PREFIX}/lib
-CPPFLAGS = -I${PREFIX}/include
-export PATH LDFLAGS CPPFLAGS
-
-ZLIB = zlib-1.2.3
-LIBTAR = libtar-1.2.11
-OPENSSL = openssl-0.9.8b
-CURL = curl-7.15.4
-FGET = fget-1.3.3
-EXPAT = expat-2.0.0
-EPKG = epkg-2.3.9
-
-all: zlib libtar openssl curl fget expat epkg
-
-zlib:
- cd ${ZLIB} && prefix=${PREFIX} CC=gcc ./configure && $(MAKE) && $(MAKE) install
-
-libtar:
- cd ${LIBTAR} && ./configure --disable-encap --disable-epkg-install --prefix=${PREFIX} && $(MAKE) && $(MAKE) install
-
-openssl:
- cd ${OPENSSL} && ./config --prefix=${PREFIX} zlib no-shared && $(MAKE) && $(MAKE) install
-
-curl:
- cd ${CURL} && ./configure --disable-ipv6 --disable-shared --prefix=${PREFIX} && $(MAKE) && $(MAKE) install
-
-fget:
- cd ${FGET} && ./configure --disable-encap --disable-epkg-install --prefix=${PREFIX} && $(MAKE) && $(MAKE) install
-
-expat:
- cd ${EXPAT} && ./configure --disable-shared --prefix=${PREFIX} && $(MAKE) && $(MAKE) install
-
-epkg:
- cd ${EPKG} && ./configure && $(MAKE) && $(MAKE) install \ No newline at end of file
diff --git a/encap/epkg/README b/encap/epkg/README
deleted file mode 100644
index 99355280b..000000000
--- a/encap/epkg/README
+++ /dev/null
@@ -1,23 +0,0 @@
-If you can't find an epkg binary compiled with all of the extra
-libraries for your platform, you can use this Makefile (which will
-probably require a little bit of editing for platforms other than
-Solaris/x86 10) to compile it.
-
-You'll need to manually download the versions of packages you want to
-this directory, edit the Makefile to refer to those versions,
-decompress/untar the distributions, and then run make (or gmake on
-non-GNU platforms)
-
-All of the software is available from http://www.dclark.us/mirror (or
-Google for it).
-
-Once you have a working epkg distribution, you should:
- * cd /usr/local/encap
- * mkencap -c epkg-x.y.z
- * Rename the tar.gz file with the appropriate encap string
- (i.e. mv epkg-x.y.z.tar.gz epkg-x.y.z-encap-i386-solaris10.tar.gz)
- * Upload that file to the encap repository at:
- http://www.encap.org/search/upload.fcgi
- * Update the ticket at http://trac.mcs.anl.gov/projects/bcfg2/ticket/74
- with a quick note stating you've done the encap upload so it can be
- mirrored at http://www.dclark.us/mirror/epkg-contrib