summaryrefslogtreecommitdiffstats
path: root/encap/epkg
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2007-03-12 16:22:51 +0000
committerNarayan Desai <desai@mcs.anl.gov>2007-03-12 16:22:51 +0000
commit6e5e9c8e969207e68665f12665a54768090897e4 (patch)
treede198777d5041073db4634a24ca37efad2a1017f /encap/epkg
parentac3eb44f16bc14e41ed62169ca36e9992509d7d6 (diff)
downloadbcfg2-6e5e9c8e969207e68665f12665a54768090897e4.tar.gz
bcfg2-6e5e9c8e969207e68665f12665a54768090897e4.tar.bz2
bcfg2-6e5e9c8e969207e68665f12665a54768090897e4.zip
Merged in certs branch in preparation for 0.9.3pre2
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@2928 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'encap/epkg')
-rw-r--r--encap/epkg/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/encap/epkg/Makefile b/encap/epkg/Makefile
index a09762b2e..acebb96e6 100644
--- a/encap/epkg/Makefile
+++ b/encap/epkg/Makefile
@@ -1,6 +1,6 @@
# $Id$
-.PHONY : all clean distclean install zlib libtar openssl curl fget expat epkg
+.PHONY : all clean distclean install zlib libtar curl fget expat epkg
.SUFFIXES :
BASEDIR = /usr/local
@@ -14,13 +14,12 @@ export PATH LDFLAGS CPPFLAGS
ZLIB = zlib-1.2.3
LIBTAR = libtar-1.2.11
-OPENSSL = openssl-0.9.8e
CURL = curl-7.15.4
FGET = fget-1.3.3
EXPAT = expat-2.0.0
EPKG = epkg-2.3.9
-all: zlib libtar openssl curl fget expat epkg
+all: zlib libtar curl fget expat epkg
zlib:
cd ${ZLIB} && prefix=${PREFIX} CC=gcc ./configure && $(MAKE) && $(MAKE) install
@@ -28,14 +27,6 @@ zlib:
libtar:
cd ${LIBTAR} && ./configure --disable-encap --disable-epkg-install --prefix=${PREFIX} && $(MAKE) && $(MAKE) install
-openssl:
- cd ${OPENSSL} && cat config | sed s:CC\=ccc:CC\=gcc:g | sed s:CC\=cc:CC\=gcc:g > config.nasa
- cd ${OPENSSL} && mv config config.orig
- cd ${OPENSSL} && cp config.nasa config
- cd ${OPENSSL} && chmod 755 config
- (cd ${OPENSSL} && ./config --prefix=${PREFIX} zlib no-asm no-shared && $(MAKE) && $(MAKE) install) || (cd ${OPENSSL} && mv config.orig config)
- cd ${OPENSSL} && mv config.orig config
-
curl:
cd ${CURL} && ./configure --disable-ipv6 --disable-shared --prefix=${PREFIX} && $(MAKE) && $(MAKE) install