summaryrefslogtreecommitdiffstats
path: root/encap/src/encap-profiles/Makefile
diff options
context:
space:
mode:
authorDaniel Joseph Barnhart Clark <dclark@pobox.com>2006-08-25 18:02:15 +0000
committerDaniel Joseph Barnhart Clark <dclark@pobox.com>2006-08-25 18:02:15 +0000
commitac390d34e412474420a82d0f32e843cc529991dd (patch)
treefea9923b01e6a2d8ba00e07a07f56f966d4b2108 /encap/src/encap-profiles/Makefile
parentb48a91771393816d04f4c31627e577c186ce8387 (diff)
downloadbcfg2-ac390d34e412474420a82d0f32e843cc529991dd.tar.gz
bcfg2-ac390d34e412474420a82d0f32e843cc529991dd.tar.bz2
bcfg2-ac390d34e412474420a82d0f32e843cc529991dd.zip
EncapPackages: Solaris sed(1) requires newline from stdin
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@2113 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'encap/src/encap-profiles/Makefile')
-rw-r--r--encap/src/encap-profiles/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/encap/src/encap-profiles/Makefile b/encap/src/encap-profiles/Makefile
index 13d3b2135..e2f57ea8e 100644
--- a/encap/src/encap-profiles/Makefile
+++ b/encap/src/encap-profiles/Makefile
@@ -133,7 +133,7 @@ rename : encaps
if [ "$(OS)x" != "x" ]; then OS="$(OS)"; fi && \
if [ "$${OS}x" != "x" ]; then \
for OLDNAME in `ls ./*-encap-*.tar.gz`; do \
- NEWNAME="`printf $${OLDNAME} \
+ NEWNAME="`printf "%s\n" "$${OLDNAME}" \
| awk -F- '{$$NF = "OSDIST.tar.gz" ; print}' \
| sed s:\ :-:g | sed s:OSDIST:\$${OS}:g`" ; \
if [ "$${OLDNAME}x" != "$${NEWNAME}x" ]; then \