summaryrefslogtreecommitdiffstats
path: root/encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep
diff options
context:
space:
mode:
authorDaniel Joseph Barnhart Clark <dclark@pobox.com>2007-07-20 00:09:19 +0000
committerDaniel Joseph Barnhart Clark <dclark@pobox.com>2007-07-20 00:09:19 +0000
commit27afe92d3622cf424203ca56e915f5ef55125294 (patch)
tree47a9df89d51579b4996a2f3426363beedef53388 /encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep
parent6e1286016d9e4aca87415ddb4266e26db1d32af9 (diff)
downloadbcfg2-27afe92d3622cf424203ca56e915f5ef55125294.tar.gz
bcfg2-27afe92d3622cf424203ca56e915f5ef55125294.tar.bz2
bcfg2-27afe92d3622cf424203ca56e915f5ef55125294.zip
EncapPackages: How's this for fun: If you have 2 seperate python binaries at different locations, both named "python", then somehow they both pick up the same python shared libraries, but if you call the second one using a different name, you get the shared library it's supposed to be using. This hit me when I installed a non-bcfg2 python in /usr/local, and suddenly bcfg2 stopped working with:
Traceback (most recent call last): File "/usr/local/bin/bcfg2", line 14, in ? import Bcfg2.Options ImportError: No module named Bcfg2.Options Because it was using the python that thought modules were under /usr/local/lib instead of /usr/local/lib/bcfg2/lib This patch should fix it. git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@3511 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep')
-rw-r--r--encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep8
1 files changed, 4 insertions, 4 deletions
diff --git a/encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep b/encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep
index 3638b412f..47fd51c9b 100644
--- a/encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep
+++ b/encap/src/encap-profiles/bcfg2-python-apt-0.6.19.ep
@@ -63,14 +63,14 @@ subdir="python-apt-0.6.19"
>
<configure>
-/usr/local/lib/bcfg2/bin/python setup.py build_ext \
+/usr/local/bin/b2-python setup.py build_ext \
-I/usr/local/lib/bcfg2/include \
-L/usr/local/lib/bcfg2/lib \
-L/usr/local/lib/bcfg2/lib/python2.4/site-packages
</configure>
<build>
-/usr/local/lib/bcfg2/bin/python setup.py build \
+/usr/local/bin/b2-python setup.py build \
--build-base=${builddir}/build
</build>
@@ -82,12 +82,12 @@ test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2 || mkdir ${ENCAP_SOURCE}/${EN
test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib
test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib/python2.4 || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib/python2.4
test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib/python2.4/site-packages || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib/python2.4/site-packages
-PYTHONPATH="${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib/python2.4/site-packages" /usr/local/lib/bcfg2/bin/python setup.py install \
+PYTHONPATH="${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2/lib/python2.4/site-packages" /usr/local/bin/b2-python setup.py install \
--prefix=${ENCAP_SOURCE}/${ENCAP_PKGNAME}/lib/bcfg2
</install>
<clean>
-/usr/local/lib/bcfg2/bin/python setup.py clean --all
+/usr/local/bin/b2-python setup.py clean --all
</clean>
</source>