summaryrefslogtreecommitdiffstats
path: root/encap
diff options
context:
space:
mode:
authorDaniel Joseph Barnhart Clark <dclark@pobox.com>2007-06-29 04:17:50 +0000
committerDaniel Joseph Barnhart Clark <dclark@pobox.com>2007-06-29 04:17:50 +0000
commit46deefef7213ac2e93d8c7251cfbd587c226fd23 (patch)
tree9cb8f5f16f2b9f61cb085c0ac9f53d33df6032f3 /encap
parentc70a4a0f31a1dd956ba5c41edc5e16533b823411 (diff)
downloadbcfg2-46deefef7213ac2e93d8c7251cfbd587c226fd23.tar.gz
bcfg2-46deefef7213ac2e93d8c7251cfbd587c226fd23.tar.bz2
bcfg2-46deefef7213ac2e93d8c7251cfbd587c226fd23.zip
EncapPackages: ...
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@3390 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'encap')
-rw-r--r--encap/src/bcfg2-site/Makefile2
-rwxr-xr-xencap/src/bcfg2-site/bcfg2-site-RENAME/postinstall.tmpl12
2 files changed, 9 insertions, 5 deletions
diff --git a/encap/src/bcfg2-site/Makefile b/encap/src/bcfg2-site/Makefile
index 1bddfc75a..624e77260 100644
--- a/encap/src/bcfg2-site/Makefile
+++ b/encap/src/bcfg2-site/Makefile
@@ -44,7 +44,7 @@ fix : copy
find $$EN -type f | xargs -n1 chmod 0644 && \
chmod 0600 $$EN/etc/ostiary.cfg && \
chmod 0600 $$EN/etc/bcfg2.conf && \
- chmod 0755 $$EN/sbin/ost-bcfg2* && \
+ chmod 0700 $$EN/sbin/ost-bcfg2* && \
chmod 0755 $$EN/postinstall
encap : fix
diff --git a/encap/src/bcfg2-site/bcfg2-site-RENAME/postinstall.tmpl b/encap/src/bcfg2-site/bcfg2-site-RENAME/postinstall.tmpl
index b00ff7dfb..68c5798d8 100755
--- a/encap/src/bcfg2-site/bcfg2-site-RENAME/postinstall.tmpl
+++ b/encap/src/bcfg2-site/bcfg2-site-RENAME/postinstall.tmpl
@@ -104,7 +104,7 @@ else
touch ${BASEDIR}/etc/.SENTINEL_SITE
fi
-# ost-bcfg2.sh
+# sbin/ost-bcfg2*
if [ "${REPLACE_CONFIG}x" = "yesx" ]; then
printf "REPLACE_CONFIG=yes, so removing ${BASEDIR}/sbin sentinel files...\n"
S_B="${BASEDIR}/sbin/.SENTINEL_BCFG2"
@@ -114,13 +114,17 @@ if [ "${REPLACE_CONFIG}x" = "yesx" ]; then
fi
if [ -f ${BASEDIR}/sbin/.SENTINEL_BCFG2 ]; then
- printf "INFO: ost-bcfg2.sh may have been updated by bcfg2 -\n"
+ printf "INFO: sbin/ost-bcfg2* may have been updated by bcfg2 -\n"
printf "INFO: not replacing that configuration with this script.\n"
elif [ -f ${BASEDIR}/sbin/.SENTINEL_SITE ]; then
- printf "INFO: ost-bcfg2.sh may have been previously updated -\n"
+ printf "INFO: sbin/ost-bcfg2* may have been previously updated -\n"
printf "INFO: not replacing that configuration with this script.\n"
else
- rmcp $PKGDIR/sbin/ost-bcfg2.sh ${BASEDIR}/sbin/
+ OSTSH="ost-bcfg2-dv ost-bcfg2-dvn ost-bcfg2-dvq ost-bcfg2-dvqn ost-bcfg2-restart ost-bcfg2.sh ost-bcfg2-v ost-bcfg2-vq"
+ for OSTFILE in $OSTSH; do
+ rmcp $PKGDIR/sbin/${OSTFILE} ${BASEDIR}/sbin/
+ done
+ chmod 700 ${BASEDIR}/sbin/*
touch ${BASEDIR}/sbin/.SENTINEL_SITE
fi