summaryrefslogtreecommitdiffstats
path: root/gentoo/bcfg2-0.9.3.ebuild
diff options
context:
space:
mode:
authorMichael Jinks <mjinks@uchicago.edu>2007-04-05 20:06:07 +0000
committerMichael Jinks <mjinks@uchicago.edu>2007-04-05 20:06:07 +0000
commit6bd2839f1ea35f8b41aeaf51b8056be6b28cad53 (patch)
tree90d5d9579769e0679a230dd34f5ca50abbf9733a /gentoo/bcfg2-0.9.3.ebuild
parentaca557677a3ae89b55e1d3d566218eb29898627f (diff)
downloadbcfg2-6bd2839f1ea35f8b41aeaf51b8056be6b28cad53.tar.gz
bcfg2-6bd2839f1ea35f8b41aeaf51b8056be6b28cad53.tar.bz2
bcfg2-6bd2839f1ea35f8b41aeaf51b8056be6b28cad53.zip
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@3017 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo/bcfg2-0.9.3.ebuild')
-rw-r--r--gentoo/bcfg2-0.9.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gentoo/bcfg2-0.9.3.ebuild b/gentoo/bcfg2-0.9.3.ebuild
new file mode 100644
index 000000000..76e5bee0c
--- /dev/null
+++ b/gentoo/bcfg2-0.9.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Bcfg2 is a configuration management tool. Package includes client
+and server."
+HOMEPAGE="http://www.mcs.anl.gov/cobalt/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-portage/gentoolkit
+ dev-python/elementtree
+ dev-python/pyopenssl
+ dev-python/lxml
+ ( || ( app-admin/gamin
+ app-admin/fam ) )"
+
+RDEPEND=""
+
+src_compile() {
+ python setup.py build
+}
+
+src_install() {
+ install -d ${D}/usr/sbin
+ install -d ${D}/etc/init.d
+ exeinto /etc/init.d
+ exeopts -m0755
+ newexe ${FILESDIR}/bcfg2-server.rc bcfg2-server
+ python setup.py install \
+ --root=${D} \
+ --record=PY_SERVER_LIBS \
+ --install-scripts /usr/sbin
+}
+
+pkg_postinst () {
+ depscan.sh
+}
+
+pkg_postrm () {
+ depscan.sh
+}