summaryrefslogtreecommitdiffstats
path: root/gentoo/bcfg2-1.1.0rc1.ebuild
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2010-11-16 13:55:01 -0600
committerSol Jerome <sol.jerome@gmail.com>2010-11-16 13:55:01 -0600
commit117f6d8aef51803a22af3687381d8e94ebb67730 (patch)
tree874f8b5ca630133d64237d18d6ca6df59971d1e9 /gentoo/bcfg2-1.1.0rc1.ebuild
parent26d630dd735d76e947289ca1ff1ed69ca1e465b4 (diff)
downloadbcfg2-117f6d8aef51803a22af3687381d8e94ebb67730.tar.gz
bcfg2-117f6d8aef51803a22af3687381d8e94ebb67730.tar.bz2
bcfg2-117f6d8aef51803a22af3687381d8e94ebb67730.zip
gentoo: Sync with latest ebuild from upstream
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'gentoo/bcfg2-1.1.0rc1.ebuild')
-rw-r--r--gentoo/bcfg2-1.1.0rc1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/gentoo/bcfg2-1.1.0rc1.ebuild b/gentoo/bcfg2-1.1.0rc1.ebuild
deleted file mode 100644
index c482a5d70..000000000
--- a/gentoo/bcfg2-1.1.0rc1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit distutils
-
-DESCRIPTION="Bcfg2 is a configuration management tool."
-HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
-
-# handle the "pre" case
-MY_P="${P/_/}"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="1"
-KEYWORDS="~amd64 ~x86"
-IUSE="server"
-
-DEPEND=">=dev-lang/python-2.5"
-
-RDEPEND="app-portage/gentoolkit
- >=dev-lang/python-2.6
- server? (
- dev-python/lxml
- app-admin/gam-server )"
-
-src_install() {
- distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
-
- # Remove files only necessary for a server installation
- if ! use server; then
- rm -rf "${D}"/usr/sbin/bcfg2-*
- rm -rf "${D}"/usr/share/bcfg2
- rm -rf "${D}"/usr/share/man/man8
- fi
-
- # Install a server init.d script
- if use server; then
- newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
- fi
-
- insinto /etc
- doins "${S}"/examples/bcfg2.conf
-}
-
-pkg_postinst () {
- use server && einfo "If this is a new installation, you probably need to run: "
- use server && einfo " bcfg2-admin init"
-}
-
-pkg_postrm () {
- python_mod_cleanup
-}