summaryrefslogtreecommitdiffstats
path: root/gentoo/bcfg2-1.1.1.ebuild
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2011-06-15 21:33:38 -0500
committerSol Jerome <sol.jerome@gmail.com>2011-06-16 15:08:38 -0500
commitc4cad655eb44d9351f0477b6ff49f8c7e039cd9b (patch)
tree22dcd9c4b7901ebb5c2505d1e3ca9863c4fede5a /gentoo/bcfg2-1.1.1.ebuild
parente7c215f9f2ddc6936cd98b3ed8b6a391fa96076b (diff)
downloadbcfg2-c4cad655eb44d9351f0477b6ff49f8c7e039cd9b.tar.gz
bcfg2-c4cad655eb44d9351f0477b6ff49f8c7e039cd9b.tar.bz2
bcfg2-c4cad655eb44d9351f0477b6ff49f8c7e039cd9b.zip
gentoo: Sync ebuild with upstream for 1.1.2
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'gentoo/bcfg2-1.1.1.ebuild')
-rw-r--r--gentoo/bcfg2-1.1.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/gentoo/bcfg2-1.1.1.ebuild b/gentoo/bcfg2-1.1.1.ebuild
deleted file mode 100644
index 1992ddaa4..000000000
--- a/gentoo/bcfg2-1.1.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-# ssl module required.
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
-
-inherit distutils
-
-DESCRIPTION="Bcfg2 is a configuration management tool."
-HOMEPAGE="http://bcfg2.org"
-
-# handle the "pre" case
-MY_P="${P/_/}"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="server"
-
-DEPEND="app-portage/gentoolkit
- server? (
- dev-python/lxml
- app-admin/gam-server )"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME="Bcfg2"
-
-distutils_src_install_post_hook() {
- if ! use server; then
- rm -f "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/sbin/bcfg2-"*
- fi
-}
-
-src_install() {
- distutils_src_install --record=PY_SERVER_LIBS --install-scripts "${EPREFIX}/usr/sbin"
-
- # Remove files only necessary for a server installation
- if ! use server; then
- rm -rf "${ED}usr/share/bcfg2"
- rm -rf "${ED}usr/share/man/man8"
- fi
-
- # Install a server init.d script
- if use server; then
- newinitd "${FILESDIR}/bcfg2-server.rc" bcfg2-server
- fi
-
- insinto /etc
- doins examples/bcfg2.conf || die "doins failed"
-}
-
-pkg_postinst () {
- distutils_pkg_postinst
-
- if use server; then
- einfo "If this is a new installation, you probably need to run:"
- einfo " bcfg2-admin init"
- fi
-}