summaryrefslogtreecommitdiffstats
path: root/gentoo/bcfg2-1.2.2.ebuild
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2012-05-19 17:41:45 -0500
committerSol Jerome <sol.jerome@gmail.com>2012-05-19 17:41:45 -0500
commitf1a40e733739bfcf83b111cc3378ba9cc06e4bc5 (patch)
tree154188d7844c7d154d190768414a9cffdcfe9722 /gentoo/bcfg2-1.2.2.ebuild
parent41ce7d4c2e96082d4500baacaee729be046f59c3 (diff)
downloadbcfg2-f1a40e733739bfcf83b111cc3378ba9cc06e4bc5.tar.gz
bcfg2-f1a40e733739bfcf83b111cc3378ba9cc06e4bc5.tar.bz2
bcfg2-f1a40e733739bfcf83b111cc3378ba9cc06e4bc5.zip
Update packaging with pyinotify dependency
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'gentoo/bcfg2-1.2.2.ebuild')
-rw-r--r--gentoo/bcfg2-1.2.2.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/gentoo/bcfg2-1.2.2.ebuild b/gentoo/bcfg2-1.2.2.ebuild
deleted file mode 100644
index c054446fe..000000000
--- a/gentoo/bcfg2-1.2.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/bcfg2-1.2.0.ebuild,v 1.1 2011/12/28 07:56:20 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-# ssl module required.
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
-
-inherit distutils
-
-DESCRIPTION="configuration management tool"
-HOMEPAGE="http://bcfg2.org"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="doc genshi server"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )"
-RDEPEND="app-portage/gentoolkit
- genshi? ( dev-python/genshi )
- server? (
- virtual/fam
- dev-python/lxml
- dev-libs/libgamin[python] )"
-
-PYTHON_MODNAME="Bcfg2"
-
-distutils_src_install_post_hook() {
- if ! use server; then
- rm -f "$(distutils_get_intermediate_installation_image)${EPREFIX}/usr/sbin/bcfg2-"*
- fi
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Building Bcfg2 documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" \
- sphinx-build doc doc_output || die
- fi
-}
-
-src_install() {
- distutils_src_install --record=PY_SERVER_LIBS --install-scripts "${EPREFIX}/usr/sbin"
-
- if ! use server; then
- # Remove files only necessary for a server installation
- rm -rf "${ED}usr/share/bcfg2" || die
- rm -rf "${ED}usr/share/man/man8" || die
- else
- newinitd "${FILESDIR}/${PN}-server-1.2.0.rc" bcfg2-server
- fi
-
- insinto /etc
- doins examples/bcfg2.conf
-
- if use doc; then
- # install the sphinx documentation
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Failed to install documentation"
- popd > /dev/null
- fi
-}
-
-pkg_postinst () {
- distutils_pkg_postinst
-
- if use server; then
- einfo "If this is a new installation, you probably need to run:"
- einfo " bcfg2-admin init"
- fi
-}