summaryrefslogtreecommitdiffstats
path: root/misc/bcfg2.spec
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2007-05-31 22:11:46 +0000
committerNarayan Desai <desai@mcs.anl.gov>2007-05-31 22:11:46 +0000
commitf5bb417f750cc4b39d8b6cc6cae31e5c95800c67 (patch)
tree2a2dd03256e88886f928bf7860153d6f5c4b5e5c /misc/bcfg2.spec
parent55a712fee1152e97f971b0fc85666f21b8c7001a (diff)
downloadbcfg2-f5bb417f750cc4b39d8b6cc6cae31e5c95800c67.tar.gz
bcfg2-f5bb417f750cc4b39d8b6cc6cae31e5c95800c67.tar.bz2
bcfg2-f5bb417f750cc4b39d8b6cc6cae31e5c95800c67.zip
Fix RPM spec for lxml (resolves Ticket #445)
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@3217 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'misc/bcfg2.spec')
-rw-r--r--misc/bcfg2.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/misc/bcfg2.spec b/misc/bcfg2.spec
index f8396944b..383fb9a52 100644
--- a/misc/bcfg2.spec
+++ b/misc/bcfg2.spec
@@ -5,6 +5,13 @@
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?_initrddir: %define _initrddir %{_sysconfdir}/rc.d/init.d}
+# Most rpm-based distributions include the lxml package a 'python-lxml',
+# but some distributions and some people who roll their own lxml packages
+# call it just 'lxml'. We'll try to catch both.
+%define dfl_lxml python-lxml
+%define alt_lxml lxml
+%define lxmldep %(rpm -q %{alt_lxml} 2>&1 > /dev/null && echo %{alt_lxml} || echo %{dfl_lxml})
+
Name: bcfg2
Version: 0.9.4
Release: %{release}
@@ -19,7 +26,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: python-devel
-Requires: python-lxml >= 0.9
+Requires: %{lxmldep} >= 0.9
%description
Bcfg2 helps system administrators produce a consistent, reproducible,