summaryrefslogtreecommitdiffstats
path: root/misc/python-ssl-1.15/debian/rules
diff options
context:
space:
mode:
authorDaniel Joseph Barnhart Clark <dclark@pobox.com>2009-12-01 09:21:40 +0000
committerDaniel Joseph Barnhart Clark <dclark@pobox.com>2009-12-01 09:21:40 +0000
commitb789371b61d4334b3016cbad0a70d794e2185b1a (patch)
tree668a335a0c5651fbc72fdd96bcd0dd57201e8c94 /misc/python-ssl-1.15/debian/rules
parent2f9f45bddddf109c7be912e996e82e23c687f8b5 (diff)
downloadbcfg2-b789371b61d4334b3016cbad0a70d794e2185b1a.tar.gz
bcfg2-b789371b61d4334b3016cbad0a70d794e2185b1a.tar.bz2
bcfg2-b789371b61d4334b3016cbad0a70d794e2185b1a.zip
Don't have a better place to put python-ssl debian packaging for now.
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@5601 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'misc/python-ssl-1.15/debian/rules')
-rwxr-xr-xmisc/python-ssl-1.15/debian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/misc/python-ssl-1.15/debian/rules b/misc/python-ssl-1.15/debian/rules
new file mode 100755
index 000000000..a7da957ff
--- /dev/null
+++ b/misc/python-ssl-1.15/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+# Unset the environment variables set by dpkg-buildpackage. (This is
+# necessary because distutils is brittle with compiler/linker flags
+# set. Specifically, packages using f2py will break without this.)
+unexport CPPFLAGS
+unexport CFLAGS
+unexport CXXFLAGS
+unexport FFLAGS
+unexport LDFLAGS
+
+PYVERS=$(shell pyversions -vr)
+
+%:
+ dh --with python-support $@
+
+# The tests include network-based tests that fail under
+# Launchpad PPA and probably sbuild, so for now disable
+# all tests. Should figure out how to run only non-network
+# tests later.
+override_dh_auto_test:
+
+# The default auto_install target gives this error:
+# copying build/lib.linux-i686-2.5/ssl/_ssl2.so -> /usr/lib/python2.5/site-packages/ssl
+# error: could not delete '/usr/lib/python2.5/site-packages/ssl/_ssl2.so': Permission denied
+override_dh_auto_install:
+ python$* setup.py install --root $(CURDIR)/debian/python-ssl