summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2011-05-11 14:40:10 -0500
committerNarayan Desai <desai@mcs.anl.gov>2011-05-11 14:40:10 -0500
commit6b4d48c2f95918e36aca674d44144c7c5ae6fe19 (patch)
tree088b411f0abca7d8db9a7a882cf389dd9f2d532c /setup.py
parent0e75875e9bd9900a6a3c7ab118c448e48829eaef (diff)
parent7a03a93da1701fd14a7c7195b01557ba3e6b24c5 (diff)
downloadbcfg2-6b4d48c2f95918e36aca674d44144c7c5ae6fe19.tar.gz
bcfg2-6b4d48c2f95918e36aca674d44144c7c5ae6fe19.tar.bz2
bcfg2-6b4d48c2f95918e36aca674d44144c7c5ae6fe19.zip
Merge branch 'master' of git.mcs.anl.gov:bcfg2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 52ec93d10..18590cc34 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,9 @@ from distutils.core import setup
from distutils.core import Command
from fnmatch import fnmatch
from glob import glob
+import os
import os.path
+import sys
class BuildDTDDoc (Command):
"""Build DTD documentation"""
@@ -113,6 +115,10 @@ try:
except ImportError:
pass
+py3lib = 'src/lib/Bcfg2Py3Incompat.py'
+if sys.hexversion < 0x03000000 and os.path.exists(py3lib):
+ os.remove(py3lib)
+
setup(cmdclass=cmdclass,
name="Bcfg2",
version="1.2.0pre2",
@@ -133,7 +139,7 @@ setup(cmdclass=cmdclass,
"Bcfg2.Server.Reports.reports.templatetags",
"Bcfg2.Server.Snapshots",
],
- package_dir = {'Bcfg2':'src/lib'},
+ package_dir = {'Bcfg2': 'src/lib'},
package_data = {'Bcfg2.Server.Reports.reports':['fixtures/*.xml',
'templates/*.html', 'templates/*/*.html',
'templates/*/*.inc' ] },