summaryrefslogtreecommitdiffstats
path: root/solaris-ips/Makefile
diff options
context:
space:
mode:
authorDan Foster <dan.foster@bristol.ac.uk>2013-05-30 14:24:00 +0000
committerDan Foster <dan.foster@bristol.ac.uk>2013-05-30 22:50:01 +0000
commite9603a3456bbf252cb40c64688088a4de2ec5b62 (patch)
treeb184afacdbe922a9a93da949ae06433846a97e8d /solaris-ips/Makefile
parent8df8b8744bd7c8fa6e539ae1289964b9411a0ef3 (diff)
downloadbcfg2-e9603a3456bbf252cb40c64688088a4de2ec5b62.tar.gz
bcfg2-e9603a3456bbf252cb40c64688088a4de2ec5b62.tar.bz2
bcfg2-e9603a3456bbf252cb40c64688088a4de2ec5b62.zip
Solaris 11 IPS Package support
Diffstat (limited to 'solaris-ips/Makefile')
-rw-r--r--solaris-ips/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/solaris-ips/Makefile b/solaris-ips/Makefile
new file mode 100644
index 000000000..343150dc5
--- /dev/null
+++ b/solaris-ips/Makefile
@@ -0,0 +1,20 @@
+#!/usr/bin/gmake
+
+VERS=1.2.4-1
+PYVERSION := $(shell python -c "import sys; print sys.version[0:3]")
+
+default: clean package
+
+package:
+ -mkdir tmp tmp/bcfg2-server tmp/bcfg2
+ -mkdir -p build/lib/$(PYVERSION)/site-packages
+ -cd ../ && PYTHONPATH=$(PYTHONPATH):$(PWD)/build/lib/python2.6/site-packages/ python setup.py install --single-version-externally-managed --record=/dev/null --prefix=$(PWD)/build/usr
+ #setuptools appears to use a restictive umask
+ -chmod -R o+r build/
+ -chmod +x build/usr/bin/bcfg2
+ -sh ./gen-manifests.sh
+
+clean:
+ -rm -rf tmp build
+ -rm -rf MANIFEST.bcfg2
+ -rm -rf MANIFEST.bcfg2-server