summaryrefslogtreecommitdiffstats
path: root/src/lib/Bcfg2/Server/SchemaUpdater/Changes
diff options
context:
space:
mode:
authorTim Laszlo <tim.laszlo@gmail.com>2012-10-08 10:38:02 -0500
committerTim Laszlo <tim.laszlo@gmail.com>2012-10-08 10:38:02 -0500
commit44638176067df5231bf0be30801e36863391cd1f (patch)
tree6aaba73d03f9a5532047518b9a3e8ef3e63d3f9f /src/lib/Bcfg2/Server/SchemaUpdater/Changes
parent1a3ced3f45423d79e08ca7d861e8118e8618d3b2 (diff)
downloadbcfg2-44638176067df5231bf0be30801e36863391cd1f.tar.gz
bcfg2-44638176067df5231bf0be30801e36863391cd1f.tar.bz2
bcfg2-44638176067df5231bf0be30801e36863391cd1f.zip
Reporting: Merge new reporting data
Move reporting data to a new schema Use south for django migrations Add bcfg2-report-collector daemon Conflicts: doc/development/index.txt doc/server/plugins/connectors/properties.txt doc/server/plugins/generators/packages.txt setup.py src/lib/Bcfg2/Client/Tools/SELinux.py src/lib/Bcfg2/Compat.py src/lib/Bcfg2/Encryption.py src/lib/Bcfg2/Options.py src/lib/Bcfg2/Server/Admin/Init.py src/lib/Bcfg2/Server/Admin/Reports.py src/lib/Bcfg2/Server/BuiltinCore.py src/lib/Bcfg2/Server/Core.py src/lib/Bcfg2/Server/FileMonitor/Inotify.py src/lib/Bcfg2/Server/Plugin/base.py src/lib/Bcfg2/Server/Plugin/interfaces.py src/lib/Bcfg2/Server/Plugins/Cfg/CfgEncryptedGenerator.py src/lib/Bcfg2/Server/Plugins/FileProbes.py src/lib/Bcfg2/Server/Plugins/Ohai.py src/lib/Bcfg2/Server/Plugins/Packages/Collection.py src/lib/Bcfg2/Server/Plugins/Packages/Source.py src/lib/Bcfg2/Server/Plugins/Packages/Yum.py src/lib/Bcfg2/Server/Plugins/Packages/__init__.py src/lib/Bcfg2/Server/Plugins/Probes.py src/lib/Bcfg2/Server/Plugins/Properties.py src/lib/Bcfg2/Server/Reports/backends.py src/lib/Bcfg2/Server/Reports/manage.py src/lib/Bcfg2/Server/Reports/nisauth.py src/lib/Bcfg2/settings.py src/sbin/bcfg2-crypt src/sbin/bcfg2-yum-helper testsuite/Testsrc/Testlib/TestServer/TestPlugins/TestProbes.py testsuite/Testsrc/Testlib/TestServer/TestPlugins/TestSEModules.py
Diffstat (limited to 'src/lib/Bcfg2/Server/SchemaUpdater/Changes')
-rw-r--r--src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_0_x.py11
-rw-r--r--src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_1_x.py59
-rw-r--r--src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_2_x.py15
-rw-r--r--src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_3_0.py27
-rw-r--r--src/lib/Bcfg2/Server/SchemaUpdater/Changes/__init__.py0
5 files changed, 0 insertions, 112 deletions
diff --git a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_0_x.py b/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_0_x.py
deleted file mode 100644
index ff4c24328..000000000
--- a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_0_x.py
+++ /dev/null
@@ -1,11 +0,0 @@
-"""
-1_0_x.py
-
-This file should contain updates relevant to the 1.0.x branches ONLY.
-The updates() method must be defined and it should return an Updater object
-"""
-from Bcfg2.Server.SchemaUpdater import UnsupportedUpdate
-
-def updates():
- return UnsupportedUpdate("1.0", 10)
-
diff --git a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_1_x.py b/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_1_x.py
deleted file mode 100644
index 0d28786fd..000000000
--- a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_1_x.py
+++ /dev/null
@@ -1,59 +0,0 @@
-"""
-1_1_x.py
-
-This file should contain updates relevant to the 1.1.x branches ONLY.
-The updates() method must be defined and it should return an Updater object
-"""
-from Bcfg2.Server.SchemaUpdater import Updater
-from Bcfg2.Server.SchemaUpdater.Routines import updatercallable
-
-from django.db import connection
-import sys
-import Bcfg2.settings
-from Bcfg2.Server.Reports.reports.models import \
- TYPE_BAD, TYPE_MODIFIED, TYPE_EXTRA
-
-@updatercallable
-def _interactions_constraint_or_idx():
- """sqlite doesn't support alter tables.. or constraints"""
- cursor = connection.cursor()
- try:
- cursor.execute('alter table reports_interaction add constraint reports_interaction_20100601 unique (client_id,timestamp)')
- except:
- cursor.execute('create unique index reports_interaction_20100601 on reports_interaction (client_id,timestamp)')
-
-
-@updatercallable
-def _populate_interaction_entry_counts():
- '''Populate up the type totals for the interaction table'''
- cursor = connection.cursor()
- count_field = {TYPE_BAD: 'bad_entries',
- TYPE_MODIFIED: 'modified_entries',
- TYPE_EXTRA: 'extra_entries'}
-
- for type in list(count_field.keys()):
- cursor.execute("select count(type), interaction_id " +
- "from reports_entries_interactions where type = %s group by interaction_id" % type)
- updates = []
- for row in cursor.fetchall():
- updates.append(row)
- try:
- cursor.executemany("update reports_interaction set " + count_field[type] + "=%s where id = %s", updates)
- except Exception:
- e = sys.exc_info()[1]
- print(e)
- cursor.close()
-
-
-def updates():
- fixes = Updater("1.1")
- fixes.override_base_version(12) # Do not do this in new code
-
- fixes.add('alter table reports_interaction add column bad_entries integer not null default -1;')
- fixes.add('alter table reports_interaction add column modified_entries integer not null default -1;')
- fixes.add('alter table reports_interaction add column extra_entries integer not null default -1;')
- fixes.add(_populate_interaction_entry_counts())
- fixes.add(_interactions_constraint_or_idx())
- fixes.add('alter table reports_reason add is_binary bool NOT NULL default False;')
- return fixes
-
diff --git a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_2_x.py b/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_2_x.py
deleted file mode 100644
index 024965bd5..000000000
--- a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_2_x.py
+++ /dev/null
@@ -1,15 +0,0 @@
-"""
-1_2_x.py
-
-This file should contain updates relevant to the 1.2.x branches ONLY.
-The updates() method must be defined and it should return an Updater object
-"""
-from Bcfg2.Server.SchemaUpdater import Updater
-from Bcfg2.Server.SchemaUpdater.Routines import updatercallable
-
-def updates():
- fixes = Updater("1.2")
- fixes.override_base_version(18) # Do not do this in new code
- fixes.add('alter table reports_reason add is_sensitive bool NOT NULL default False;')
- return fixes
-
diff --git a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_3_0.py b/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_3_0.py
deleted file mode 100644
index 4fc57c653..000000000
--- a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/1_3_0.py
+++ /dev/null
@@ -1,27 +0,0 @@
-"""
-1_3_0.py
-
-This file should contain updates relevant to the 1.3.x branches ONLY.
-The updates() method must be defined and it should return an Updater object
-"""
-from Bcfg2.Server.SchemaUpdater import Updater, UpdaterError
-from Bcfg2.Server.SchemaUpdater.Routines import AddColumns, \
- RemoveColumns, RebuildTable, DropTable
-
-from Bcfg2.Server.Reports.reports.models import Reason, Interaction
-
-
-def updates():
- fixes = Updater("1.3")
- fixes.add(RemoveColumns(Interaction, 'client_version'))
- fixes.add(AddColumns(Reason))
- fixes.add(RebuildTable(Reason, [
- 'owner', 'current_owner',
- 'group', 'current_group',
- 'perms', 'current_perms',
- 'status', 'current_status',
- 'to', 'current_to']))
- fixes.add(DropTable('reports_ping'))
-
- return fixes
-
diff --git a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/__init__.py b/src/lib/Bcfg2/Server/SchemaUpdater/Changes/__init__.py
deleted file mode 100644
index e69de29bb..000000000
--- a/src/lib/Bcfg2/Server/SchemaUpdater/Changes/__init__.py
+++ /dev/null