summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index fcbf6346c..eaf80a4d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,20 @@
#!/usr/bin/make -f
-%:
- dh $@ --with python-support,sphinxdoc
+# Lucid does not have dh_python2, but we would like to be able to use
+# this rules file to build on lucid as well.
+WITH_PYTHON2 = $(shell test -f /usr/bin/dh_python2 && echo "--with python2")
+WITH_SPHINXDOC = $(shell test -f /usr/bin/dh_sphinxdoc && echo "--with sphinxdoc")
-override_dh_auto_install:
- # Make the build destination dir consistent between pre-7.3 and 7.3 and
- # later debhelper - see http://bcfg2.org/ticket/791
- dh_auto_install
- test -d debian/tmp/usr/local && mv debian/tmp/usr/local/* debian/tmp/usr || exit 0
- test -d debian/tmp/usr/local && rmdir debian/tmp/usr/local || exit 0
+%:
+ dh $@ ${WITH_PYTHON2} ${WITH_SPHINXDOC}
override_dh_installinit:
# Install bcfg2 initscript without starting it on postinst
dh_installinit --package=bcfg2 --no-start
# Install bcfg2-server initscript without starting it on postinst
dh_installinit --package=bcfg2-server --no-start
+ # Install bcfg2-report-collector initscript without starting it on postinst
+ dh_installinit --package=bcfg2-server --name=bcfg2-report-collector --no-start
override_dh_auto_build:
dh_auto_build