summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-x[-rw-r--r--]debian/bcfg2.cron.daily14
-rwxr-xr-x[-rw-r--r--]debian/bcfg2.cron.hourly14
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
4 files changed, 31 insertions, 5 deletions
diff --git a/debian/bcfg2.cron.daily b/debian/bcfg2.cron.daily
index 92e8ff02c..b28b2062b 100644..100755
--- a/debian/bcfg2.cron.daily
+++ b/debian/bcfg2.cron.daily
@@ -1,3 +1,13 @@
#!/bin/sh
-[ -x /usr/lib/bcfg2/bcfg2-cron ] || exit 0
-/usr/lib/bcfg2/bcfg2-cron --daily > /dev/null 2>&1 || true
+BCFG2CRON=
+if [[ -x /usr/libexec/bcfg2-cron ]]; then
+ BCFG2CRON=/usr/libexec/bcfg2-cron
+elif [[ -x /usr/lib/bcfg2/bcfg2-cron ]]; then
+ BCFG2CRON=/usr/lib/bcfg2/bcfg2-cron
+elif type bcfg2-cron >& /dev/null; then
+ BCFG2CRON=bcfg2-cron
+else
+ echo "No bcfg2-cron command found"
+ exit 1
+fi
+$BCFG2CRON --daily 2>&1 | logger -t bcfg2-cron -p daemon.info
diff --git a/debian/bcfg2.cron.hourly b/debian/bcfg2.cron.hourly
index 1fdb9c30e..300792885 100644..100755
--- a/debian/bcfg2.cron.hourly
+++ b/debian/bcfg2.cron.hourly
@@ -1,3 +1,13 @@
#!/bin/sh
-[ -x /usr/lib/bcfg2/bcfg2-cron ] || exit 0
-/usr/lib/bcfg2/bcfg2-cron --hourly > /dev/null 2>&1 || true
+BCFG2CRON=
+if [[ -x /usr/libexec/bcfg2-cron ]]; then
+ BCFG2CRON=/usr/libexec/bcfg2-cron
+elif [[ -x /usr/lib/bcfg2/bcfg2-cron ]]; then
+ BCFG2CRON=/usr/lib/bcfg2/bcfg2-cron
+elif type bcfg2-cron >& /dev/null; then
+ BCFG2CRON=bcfg2-cron
+else
+ echo "No bcfg2-cron command found"
+ exit 1
+fi
+$BCFG2CRON --hourly 2>&1 | logger -t bcfg2-cron -p daemon.info
diff --git a/debian/changelog b/debian/changelog
index 2557dd66a..c77acc0e7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+bcfg2 (1.2.3-0.0) unstable; urgency=low
+
+ * New upstream release
+
+ -- Sol Jerome <sol.jerome@gmail.com> Tue, 03 Jul 2012 09:33:50 -0500
+
bcfg2 (1.2.2-0.0) unstable; urgency=low
* New upstream release
diff --git a/debian/control b/debian/control
index 7835334da..ae8b6a2d5 100644
--- a/debian/control
+++ b/debian/control
@@ -21,7 +21,7 @@ Description: Configuration management client
Package: bcfg2-server
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-lxml (>= 0.9), libxml2-utils (>= 2.6.23), lsb-base (>= 3.1-9), ucf, bcfg2 (= ${binary:Version}), openssl, python-ssl | python2.6 | python3.0 | python3.1 | python3.2, python-gamin
+Depends: ${python:Depends}, ${misc:Depends}, python-lxml (>= 0.9), libxml2-utils (>= 2.6.23), lsb-base (>= 3.1-9), ucf, bcfg2 (= ${binary:Version}), openssl, python-ssl | python2.6 | python3.0 | python3.1 | python3.2, python-pyinotify | python-gamin
XB-Python-Version: >= 2.4
Recommends: graphviz, patch
Suggests: python-cheetah, python-genshi (>= 0.4.4), python-profiler, python-sqlalchemy (>= 0.5.0), python-django, mail-transport-agent, bcfg2-doc (= ${binary:Version})