summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/bcfg2-server.bcfg2-report-collector.init (renamed from debian/bcfg2-report-collector.init)0
-rw-r--r--debian/bcfg2-server.postinst17
-rwxr-xr-xdebian/bcfg2.cron.daily2
-rwxr-xr-xdebian/bcfg2.cron.hourly2
-rw-r--r--debian/bcfg2.default2
-rw-r--r--debian/changelog12
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules9
8 files changed, 28 insertions, 23 deletions
diff --git a/debian/bcfg2-report-collector.init b/debian/bcfg2-server.bcfg2-report-collector.init
index df7b751cb..df7b751cb 100755
--- a/debian/bcfg2-report-collector.init
+++ b/debian/bcfg2-server.bcfg2-report-collector.init
diff --git a/debian/bcfg2-server.postinst b/debian/bcfg2-server.postinst
index 2f65fe847..77dea5f22 100644
--- a/debian/bcfg2-server.postinst
+++ b/debian/bcfg2-server.postinst
@@ -40,21 +40,4 @@ esac
#DEBHELPER#
-# We do a restart manually here because with autogenerated code
-# we get this traceback (eg something isn't done yet):
-# This happens due to debhelper bug #546293, fixed in version 7.4.2.
-## Setting up bcfg2-server (1.0.0~rc3+r5542-0.1+dctest8) ...
-## Starting Configuration Management Server: Traceback (most recent call last):
-## File "/usr/sbin/bcfg2-server", line 12, in <module>
-## import Bcfg2.Server.Plugins.Metadata
-## ImportError: No module named Server.Plugins.Metadata
-## * bcfg2-server
-if [ -x "/etc/init.d/bcfg2-server" ]; then
- if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
- invoke-rc.d bcfg2-server start || exit $?
- else
- /etc/init.d/bcfg2-server start || exit $?
- fi
-fi
-
exit 0
diff --git a/debian/bcfg2.cron.daily b/debian/bcfg2.cron.daily
index f2d1efb9f..b872887cb 100755
--- a/debian/bcfg2.cron.daily
+++ b/debian/bcfg2.cron.daily
@@ -10,4 +10,4 @@ else
echo "No bcfg2-cron command found"
exit 1
fi
-$BCFG2CRON --daily 2>&1 | logger -t bcfg2-cron -p daemon.info
+$BCFG2CRON --daily 2>&1 | logger -t bcfg2-cron -p daemon.info -i
diff --git a/debian/bcfg2.cron.hourly b/debian/bcfg2.cron.hourly
index 73aae7606..9f666e083 100755
--- a/debian/bcfg2.cron.hourly
+++ b/debian/bcfg2.cron.hourly
@@ -10,4 +10,4 @@ else
echo "No bcfg2-cron command found"
exit 1
fi
-$BCFG2CRON --hourly 2>&1 | logger -t bcfg2-cron -p daemon.info
+$BCFG2CRON --hourly 2>&1 | logger -t bcfg2-cron -p daemon.info -i
diff --git a/debian/bcfg2.default b/debian/bcfg2.default
index 0164e5531..8ed0da74a 100644
--- a/debian/bcfg2.default
+++ b/debian/bcfg2.default
@@ -20,7 +20,7 @@
#BCFG2_INIT=1
# BCFG2_AGENT:
-# Bcfg2 no longer supports agent mode please use the Agent+SSH method
+# Bcfg2 no longer supports agent mode, please see NEWS.Debian
# BCFG2_CRON:
# Set the frequency of cron runs.
diff --git a/debian/changelog b/debian/changelog
index 298e695c5..7f6e2f637 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+bcfg2 (1.3.3-0.0) unstable; urgency=low
+
+ * New upstream release
+
+ -- Sol Jerome <sol.jerome@gmail.com> Thu, 07 Nov 2013 08:09:57 -0600
+
+bcfg2 (1.3.2-0.0) unstable; urgency=low
+
+ * New upstream release
+
+ -- Sol Jerome <sol.jerome@gmail.com> Mon, 01 Jul 2013 16:24:46 -0500
+
bcfg2 (1.3.1-0.0) unstable; urgency=low
* New upstream release
diff --git a/debian/control b/debian/control
index 20cef93c8..aee6f1c24 100644
--- a/debian/control
+++ b/debian/control
@@ -9,11 +9,14 @@ Build-Depends: debhelper (>= 7.0.50~),
python-sphinx (>= 1.0.7+dfsg) | python3-sphinx,
python-lxml,
python-daemon,
- python-cherrypy,
+ python-boto,
+ python-cherrypy3,
python-gamin,
+ python-genshi,
python-pyinotify,
python-m2crypto,
python-doc,
+ python-mock,
python-mock-doc
Build-Depends-Indep: python-support (>= 0.5.3)
Standards-Version: 3.8.0.0
@@ -41,7 +44,7 @@ Description: Configuration management server
Package: bcfg2-web
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, bcfg2-server (= ${binary:Version}), python-django,
+Depends: ${python:Depends}, ${misc:Depends}, bcfg2-server (= ${binary:Version}), python-django, python-django-south (>= 0.7.5)
Suggests: python-mysqldb, python-psycopg2, python-sqlite, libapache2-mod-wsgi
Description: Configuration management web interface
Bcfg2 is a configuration management system that generates configuration sets
diff --git a/debian/rules b/debian/rules
index 5694e4e37..eaf80a4d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,20 @@
#!/usr/bin/make -f
+# Lucid does not have dh_python2, but we would like to be able to use
+# this rules file to build on lucid as well.
+WITH_PYTHON2 = $(shell test -f /usr/bin/dh_python2 && echo "--with python2")
+WITH_SPHINXDOC = $(shell test -f /usr/bin/dh_sphinxdoc && echo "--with sphinxdoc")
+
%:
- dh $@ --with python-support,sphinxdoc
+ dh $@ ${WITH_PYTHON2} ${WITH_SPHINXDOC}
override_dh_installinit:
# Install bcfg2 initscript without starting it on postinst
dh_installinit --package=bcfg2 --no-start
# Install bcfg2-server initscript without starting it on postinst
dh_installinit --package=bcfg2-server --no-start
+ # Install bcfg2-report-collector initscript without starting it on postinst
+ dh_installinit --package=bcfg2-server --name=bcfg2-report-collector --no-start
override_dh_auto_build:
dh_auto_build