summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 033aed4c8..3c5be6f52 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,13 @@
%:
dh --with python-support $@
+override_dh_auto_install:
+ # Make the build destination dir consistent between pre-7.3 and 7.3 and
+ # later debhelper - see http://bcfg2.org/ticket/791
+ dh_auto_install
+ test -d debian/tmp/usr/local && mv debian/tmp/usr/local/* debian/tmp/usr || exit 0
+ test -d debian/tmp/usr/local && rmdir debian/tmp/usr/local || exit 0
+
override_dh_installinit:
# Install bcfg2 initscript without staring it on postinst
dh_installinit --package=bcfg2 --no-start