summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/install.xml10
1 files changed, 9 insertions, 1 deletions
diff --git a/doc/install.xml b/doc/install.xml
index 48498a735..3f397ccb8 100644
--- a/doc/install.xml
+++ b/doc/install.xml
@@ -134,8 +134,16 @@ $ python setup.py install
<para>SSL is used for channel-level data encryption. The
requisite SSL certificates must be generated on the server
- side. I need to figure out how to do this.
+ side. The following command will generate a server key:
</para>
+
+ <programlisting>
+openssl req -x509 -nodes -days 1000 -newkey rsa:1024 -out server.pem -keyout server.pem
+ </programlisting>
+
+ <para>This command will generate an SSL key including both an
+ RSA key and a certificate. This is suitable for use with the
+ Bcfg2 XML-RPC server.</para>
</sect2>