summaryrefslogtreecommitdiffstats
path: root/encap/src/encap-profiles
diff options
context:
space:
mode:
Diffstat (limited to 'encap/src/encap-profiles')
-rw-r--r--encap/src/encap-profiles/Makefile8
-rw-r--r--encap/src/encap-profiles/bcfg2-python-2.4.3.ep12
2 files changed, 20 insertions, 0 deletions
diff --git a/encap/src/encap-profiles/Makefile b/encap/src/encap-profiles/Makefile
index f2c4d04b9..664aea619 100644
--- a/encap/src/encap-profiles/Makefile
+++ b/encap/src/encap-profiles/Makefile
@@ -141,6 +141,14 @@ rename : encaps
fi; \
done; \
fi
+ for OLDNAME in `ls ./*-doc-*-encap-*.tar.gz`; do \
+ NEWNAME="`printf "%s\n" "$${OLDNAME}" \
+ | awk -F- '{$$NF = "OSDIST.tar.gz" ; print}' \
+ | sed s:\ :-:g | sed s:OSDIST:share:g`" ; \
+ if [ "$${OLDNAME}x" != "$${NEWNAME}x" ]; then \
+ mv ./$${OLDNAME} ./$${NEWNAME}; \
+ fi; \
+ done;
clean :
-(rm ./*.log; rm ./*.packaged; rm ./*.gz; rm ./*~)
diff --git a/encap/src/encap-profiles/bcfg2-python-2.4.3.ep b/encap/src/encap-profiles/bcfg2-python-2.4.3.ep
index 454aeced1..d94aba979 100644
--- a/encap/src/encap-profiles/bcfg2-python-2.4.3.ep
+++ b/encap/src/encap-profiles/bcfg2-python-2.4.3.ep
@@ -83,6 +83,18 @@ PLATFORM_ENDIF
--disable-ipv6
</configure>
+<build type="append"><![CDATA[
+# Make sure linking to openssl worked
+${builddir}/python -c "from httplib import HTTPS" || HS="no"; \
+if [ "${HS}x" = "nox" ]; then \
+ printf "ERROR: HTTPS fails (usually a problem with linking against "; \
+ printf "openssl), aborting...\n"; \
+ exit 1; \
+else \
+ printf "INFO: HTTPS works\n"; \
+fi
+]]></build>
+
</source>
<prepackage><![CDATA[