summaryrefslogtreecommitdiffstats
path: root/encap/tools/bcfg2-python-apt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'encap/tools/bcfg2-python-apt/Makefile')
-rw-r--r--encap/tools/bcfg2-python-apt/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/encap/tools/bcfg2-python-apt/Makefile b/encap/tools/bcfg2-python-apt/Makefile
index 929bc97ec..0e4740002 100644
--- a/encap/tools/bcfg2-python-apt/Makefile
+++ b/encap/tools/bcfg2-python-apt/Makefile
@@ -12,7 +12,13 @@ export EPKG
MKENCAP = ${BASEDIR}/bin/mkencap
export MKENCAP
+APTMAJOR := $(shell apt-get --version | head -1 | cut -c 7)
+
+ifeq ($(APTMAJOR),5)
+PYTHON-APT = bcfg2-python-apt-0.5.10
+else ifeq ($(APTMAJOR),6)
PYTHON-APT = bcfg2-python-apt-0.6.19
+endif
.ep.installed : # Clean, compile and install an encap package
@printf "***** START .ep.installed for |$*| ***** \n"