summaryrefslogtreecommitdiffstats
path: root/encap/tools/ostiary
diff options
context:
space:
mode:
Diffstat (limited to 'encap/tools/ostiary')
-rw-r--r--encap/tools/ostiary/Makefile65
-rw-r--r--encap/tools/ostiary/ostiary-3.4.ep122
-rw-r--r--encap/tools/ostiary/ostiary-doc-20060801.ep58
3 files changed, 0 insertions, 245 deletions
diff --git a/encap/tools/ostiary/Makefile b/encap/tools/ostiary/Makefile
deleted file mode 100644
index f7885f1c5..000000000
--- a/encap/tools/ostiary/Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
-# $Id:$
-
-.PHONY : all install clean uninstall encaps rename
-.SUFFIXES :
-.SUFFIXES : .ep .installed .packaged
-
-BASEDIR = /usr/local
-ENCAPDIR = ${BASEDIR}/encap
-export ENCAPDIR
-EPKG = ${BASEDIR}/bin/epkg
-export EPKG
-MKENCAP = ${BASEDIR}/bin/mkencap
-export MKENCAP
-
-OSTIARTY = ostiary-3.4
-OSTIARTY-DOC = ostiary-doc-20060801
-
-.ep.installed : # Clean, compile and install an encap package
- @printf "***** START .ep.installed for |$*| ***** \n"
- ( ${EPKG} -q -r ${ENCAPDIR}/$* || true )
- ( rm -rf ${ENCAPDIR}/$* || true )
- ( ${MKENCAP} -m /usr/local/bin/m4 -b -DUP $*.ep || true ) > $*.log 2>&1
- ( ${MKENCAP} -m /usr/local/bin/m4 -b -T $*.ep || true ) >> $*.log 2>&1
- ( ${MKENCAP} -m /usr/local/bin/m4 -b -CBI $*.ep ) >> $*.log 2>&1
- ${EPKG} -q -i ${ENCAPDIR}/$*
- test -h ${BASEDIR}/var/encap/$*
- touch $*.installed
- @printf "***** STOP .ep.installed for |$*| ***** \n"
-
-.installed.packaged : # Create .tar.gz encap packages for distribution
- @printf "***** START .installed.packaged for |$*| ***** \n"
- ( rm ${ENCAPDIR}/$*-*.tar.gz || true )
- ( cd ${ENCAPDIR} && ${MKENCAP} -e $* || true )
- cd ${ENCAPDIR} && ${MKENCAP} -c $*
- mv ${ENCAPDIR}/$*-encap-*.tar.gz .
- touch $*.packaged
- @printf "***** STOP .installed.packaged for |$*| ***** \n"
-
-all :
- ( $(MAKE) install > make.log 2>&1 && $(MAKE) encaps >> make.log 2>&1 ) &
-
-install : ${EPKG} ${MKENCAP} ${OSTIARTY-DOC}.installed
-
-encaps : ${EPKG} ${MKENCAP} ${OSTIARTY-DOC}.packaged
-
-rename : encaps
- test "$${OS}x" != "x"
- for EARCHIVE in `ls *-encap-*.tar.gz`; do \
- mv $${EARCHIVE} `printf $${EARCHIVE} | awk -F- '{$$NF = "OSDIST.tar.gz" ; print}' | sed s:\ :-:g | sed s:OSDIST:\$${OS}:g` ; \
- done
-
-clean :
- ( rm *.log || true )
- ( rm *.packaged || true )
- ( rm *.gz || true )
- ( rm *~ || true )
-
-uninstall : clean
- ( rm *.installed || true )
- ( ${EPKG} -q -r ${ENCAPDIR}/ostiary* || true )
- ( rm -rf ${ENCAPDIR}/ostiary* || true )
-
-${OSTIARTY-DOC}.installed : ${OSTIARTY}.installed
-
-${OSTIARTY-DOC}.packaged : ${OSTIARTY}.packaged
diff --git a/encap/tools/ostiary/ostiary-3.4.ep b/encap/tools/ostiary/ostiary-3.4.ep
deleted file mode 100644
index be0c4fbdb..000000000
--- a/encap/tools/ostiary/ostiary-3.4.ep
+++ /dev/null
@@ -1,122 +0,0 @@
-<?xml version="1.0"?>
-
-<!-- $Id$ -->
-
-<encap_profile
- profile_ver="1.0"
- pkgspec="ostiary-3.4"
->
-
-<prereq package="patch-2.5.9" />
-<prereq package="m4-1.4.4" />
-
-<environment
- variable="CC"
- value="gcc"
- type="set"
-/>
-
-<environment
- variable="PATH"
-PLATFORM_IF_MATCH(solaris)
- value="/usr/local/lib/bcfg2/bin:/usr/local/bin:/usr/sfw/bin:/usr/ccs/bin:"
-PLATFORM_ELSE
- value="/usr/local/lib/bcfg2/bin:/usr/local/bin:"
-PLATFORM_ENDIF
- type="prepend"
-/>
-
-PLATFORM_IF_MATCH(linux)
-PLATFORM_ELSE
-<environment
- variable="MAKE"
- value="gmake"
- type="set"
-/>
-PLATFORM_ENDIF
-
-<source
-url="http://www.pobox.com/users/dclark/mirror/ostiary/ostiary-3.4.tar.gz
- http://ingles.homeunix.org/software/ost/ostiary-3.4.tar.gz"
- use_objdir="no"
->
-
-<patch options="-p1"><![CDATA[
-#
-# Allow up to 32 Actions (up from 8)...
-#
---- ostiary-3.4/ost.h 2006-08-16 23:31:59.000000000 -0400
-+++ ostiary-3.4.new/ost.h 2006-08-16 23:33:23.000000000 -0400
-@@ -22,7 +22,7 @@
- /* Note: strictly IPv4 for now... */
- #define MAX_SIZEOF_IP 16
-
--#define MAX_NUM_SECRETS 8
-+#define MAX_NUM_SECRETS 32
- #define MAX_NUM_CACHED_IPS 128
-
- #define MAX_SECRET_SIZE 64
-@@ -53,7 +53,7 @@
- /* Note: strictly IPv4 for now... */
- #define MAX_SIZEOF_IP 16
-
--#define MAX_NUM_SECRETS 8
-+#define MAX_NUM_SECRETS 32
- #define MAX_NUM_CACHED_IPS 128
-
- /* You can make MAX_SECRET_SIZE bigger, but don't forget to update
-]]></patch>
-
-</source>
-
-<prepackage>
-# /usr/local/etc stuff
-mkdir share 2>/dev/null || exit 1
-mkdir share/doc 2>/dev/null || exit 1
-mkdir share/doc/ostiary 2>/dev/null || exit 1
-mkdir share/doc/ostiary/examples 2>/dev/null || exit 1
-mv etc/ostiary.cfg share/doc/ostiary/examples/ostiary.cfg
-rmdir etc
-# daemons should be in /usr/local/sbin
-mkdir sbin 2>/dev/null || exit 1
-mv bin/ostiaryd sbin/ostiaryd
-# daemontool stuff
-mkdir var 2>/dev/null || exit 1
-mkdir var/svc.d 2>/dev/null || exit 1
-mkdir var/svc.d/ostiary 2>/dev/null || exit 1
-mkdir var/svc.d/ostiary/log 2>/dev/null || exit 1
-# encap stuff
-mkdir var/encap 2>/dev/null || exit 0
-touch var/encap/${ENCAP_PKGNAME}
-</prepackage>
-
-<include_file name="var/svc.d/ostiary/run" mode="0755"><![CDATA[
-#!/bin/sh
-exec 2>&1
-exec /usr/local/sbin/ostiaryd -c /usr/local/etc/ostiary.cfg -v -D
-]]></include_file>
-
-<include_file name="var/svc.d/ostiary/log/run" mode="0755"><![CDATA[
-#!/bin/sh
-exec 2>&1
-exec /command/multilog t /usr/local/var/multilog/ostiary
-]]></include_file>
-
-<include_file name="postinstall" mode="0755"><![CDATA[
-#!/bin/sh -e
-umask 002
-BASEDIR="`echo ${0} | xargs -n1 dirname`"
-LOG=${BASEDIR}/postinstall.log
-exec > $LOG 2>&1
-printf "Running ostiary postinstall script...\n"
-date
-test -d /usr/local/var/multilog || mkdir /usr/local/var/multilog
-test -d /usr/local/var/multilog/ostiary || mkdir /usr/local/var/multilog/ostiary
-printf "Finished ostiary postinstall script.\n"
-]]></include_file>
-
-<encapinfo>
-description Ostiary - Simple, Secure Remote Script Execution
-</encapinfo>
-
-</encap_profile>
diff --git a/encap/tools/ostiary/ostiary-doc-20060801.ep b/encap/tools/ostiary/ostiary-doc-20060801.ep
deleted file mode 100644
index 3b0251f2e..000000000
--- a/encap/tools/ostiary/ostiary-doc-20060801.ep
+++ /dev/null
@@ -1,58 +0,0 @@
-<?xml version="1.0"?>
-
-<!-- $Id$ -->
-
-<encap_profile
- profile_ver="1.0"
- pkgspec="ostiary-doc-20060801"
->
-
-<environment
- variable="PATH"
-PLATFORM_IF_MATCH(solaris)
- value="/usr/local/lib/bcfg2/bin:/usr/local/bin:/usr/sfw/bin:/usr/ccs/bin:"
-PLATFORM_ELSE
- value="/usr/local/lib/bcfg2/bin:/usr/local/bin:"
-PLATFORM_ENDIF
- type="prepend"
-/>
-
-<source
-url="http://www.pobox.com/users/dclark/mirror/ostiary/ostiary-doc-20060801.tar.gz"
- use_objdir="no"
->
-
-<configure>
-:
-</configure>
-
-<build>
-:
-</build>
-
-<install>
-test -d ${ENCAP_SOURCE} || mkdir ${ENCAP_SOURCE}
-test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME} || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}
-test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share
-test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share/doc || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share/doc
-test -d ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share/doc/ostiary || mkdir ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share/doc/ostiary
-cp * ${ENCAP_SOURCE}/${ENCAP_PKGNAME}/share/doc/ostiary
-</install>
-
-<clean>
-:
-</clean>
-
-</source>
-
-<prepackage>
-mkdir var 2>/dev/null || exit 0
-mkdir var/encap 2>/dev/null || exit 0
-touch var/encap/${ENCAP_PKGNAME}
-</prepackage>
-
-<encapinfo>
-description ostiary-doc - documentation from ostiary website
-</encapinfo>
-
-</encap_profile>