summaryrefslogtreecommitdiffstats
path: root/misc/bcfg2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'misc/bcfg2.spec')
-rw-r--r--misc/bcfg2.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/misc/bcfg2.spec b/misc/bcfg2.spec
index 357afed4e..443e0d27a 100644
--- a/misc/bcfg2.spec
+++ b/misc/bcfg2.spec
@@ -18,11 +18,11 @@
# characters from the appropriate line below.
#
# Don't forget to change the Release: tag below to something like 0.1
-#%%global _rc 1
-%global _pre pre1
+#%%global _rc rc1
+%global _pre pre2
%global _nightly 1
%global _date %(date +%Y%m%d)
-%global _pre_rc %{?_pre:pre%{_pre}}%{?_rc:rc%{_rc}}
+%global _pre_rc %{?_pre:%{_pre}}%{?_rc:%{_rc}}
# cherrypy 3.3 actually doesn't exist yet, but 3.2 has bugs that
# prevent it from working:
@@ -56,6 +56,8 @@ BuildRequires: python
BuildRequires: python-devel
BuildRequires: python-lxml
BuildRequires: python-boto
+BuildRequires: python-argparse
+BuildRequires: python-jinja2
%if 0%{?suse_version}
BuildRequires: python-M2Crypto
BuildRequires: python-Genshi
@@ -83,9 +85,9 @@ BuildRequires: mock
BuildRequires: m2crypto
# EPEL uses the properly-named python-django starting with EPEL7
%if 0%{?rhel} && 0%{?rhel} > 6
-BuildRequires: python-django
+BuildRequires: python-django >= 1.3
%else
-BuildRequires: Django
+BuildRequires: Django >= 1.3
%endif
BuildRequires: python-genshi
BuildRequires: python-cheetah
@@ -137,6 +139,8 @@ BuildRequires: systemd-units
Requires: python-ssl
%endif
Requires: libselinux-python
+Requires: pylibacl
+Requires: python-argparse
%if 0%{?fedora} >= 16
Requires(post): systemd-units
@@ -192,6 +196,7 @@ Group: System Environment/Daemons
%endif
Requires: bcfg2 = %{version}-%{release}
Requires: python-lxml >= 1.2.1
+Requires: python-genshi
%if 0%{?suse_version}
Requires: python-pyinotify
Requires: python-python-daemon
@@ -298,15 +303,15 @@ Requires: bcfg2-server = %{version}-%{release}
Requires: httpd
%if 0%{?suse_version}
Group: System/Management
-Requires: python-django >= 1.2
+Requires: python-django >= 1.3
Requires: python-django-south >= 0.7
%else
Group: System Tools
# EPEL uses the properly-named python-django starting with EPEL7
%if 0%{?rhel} && 0%{?rhel} > 6
-Requires: python-django
+Requires: python-django > 1.3
%else
-Requires: Django >= 1.2
+Requires: Django >= 1.3
Requires: Django-south >= 0.7
%endif
Requires: bcfg2-server
@@ -662,7 +667,7 @@ sed "s@http://www.w3.org/2001/xml.xsd@file://$(pwd)/schemas/xml.xsd@" \
# Required for EL5 and OpenSUSE
%defattr(-,root,root,-)
%endif
-%doc COPYRIGHT LICENSE README
+%doc COPYRIGHT LICENSE README.rst
%{_mandir}/man1/bcfg2.1*
%{_mandir}/man5/bcfg2.conf.5*
%ghost %attr(600,root,root) %config(noreplace,missingok) %{_sysconfdir}/bcfg2.cert
@@ -714,7 +719,9 @@ sed "s@http://www.w3.org/2001/xml.xsd@file://$(pwd)/schemas/xml.xsd@" \
%{python_sitelib}/Bcfg2/Server
%{python_sitelib}/Bcfg2/Reporting
%{python_sitelib}/Bcfg2/manage.py*
+%if %{build_cherry_py}
%exclude %{python_sitelib}/Bcfg2/Server/CherryPyCore.py*
+%endif
%dir %{_datadir}/bcfg2
%{_datadir}/bcfg2/schemas