summaryrefslogtreecommitdiffstats
path: root/tools/export.py
diff options
context:
space:
mode:
Diffstat (limited to 'tools/export.py')
-rwxr-xr-xtools/export.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/export.py b/tools/export.py
index c64ff90a2..83f13923b 100755
--- a/tools/export.py
+++ b/tools/export.py
@@ -59,6 +59,11 @@ for line in fileinput.input('solaris/Makefile', inplace=1):
if line.startswith('VERS='):
line = line.replace(line, 'VERS=%s-1\n' % version)
sys.stdout.write(line)
+# update the version in reports
+for line in fileinput.input('src/lib/Server/Reports/reports/templates/base.html', inplace=1):
+ if 'Bcfg2 Version' in line:
+ line = line.replace(line, ' <span>Bcfg2 Version %s</span>\n' % version)
+ sys.stdout.write(line)
# tag the release
#FIXME: do this using python-dulwich