summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2015-09-02 00:55:25 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2015-09-02 01:02:37 +0200
commitc060dc8d10375a409893a98d0661b41daf4f362f (patch)
tree92ce7778aeb34f9e3d2829f254055a22f1d614ff
parent5d4391a17b27e10ed74d6b692ae7d33b47cfced0 (diff)
downloadspline-startup-c060dc8d10375a409893a98d0661b41daf4f362f.tar.gz
spline-startup-c060dc8d10375a409893a98d0661b41daf4f362f.tar.bz2
spline-startup-c060dc8d10375a409893a98d0661b41daf4f362f.zip
Debianization
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control17
-rw-r--r--debian/copyright3
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/source/format1
-rw-r--r--debian/spline-startup.default2
-rw-r--r--debian/spline-startup.init98
9 files changed, 131 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..6b62776
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+spline-startup (1.0-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Alexander Sulfrian <alex@spline.inf.fu-berlin.de> Tue, 01 Sep 2015 04:02:01 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..45a4fb7
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+8
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..55268bf
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: spline-startup
+Section: admin
+Priority: extra
+Maintainer: Alexander Sulfrian <alex@spline.inf.fu-berlin.de>
+Build-Depends: debhelper (>= 7.0.50~)
+Standards-Version: 3.8.4
+Homepage: https://doku.spline.inf.fu-berlin.de/infrastruktur/software/spline-startup
+Vcs-Git: git://git.spline.inf.fu-berlin.de/server/spline-startup
+Vcs-Browser: http://git.spline.inf.fu-berlin.de/server/spline-startup/
+
+Package: spline-startup
+Architecture: all
+Depends: ${misc:Depends}, lsb-base (>= 3.0-6), debianutils, python,
+ python-argparse
+Description: startup for user daemons
+ spline-startup invokes init scripts of users located in their
+ $HOME/etc/rc.d directory.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..f4c1e62
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,3 @@
+Files: *
+Copyright: 2015 Alexander Sulfrian <alex@spline.inf.fu-berlin.de>
+License: Expat
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..215b66a
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+spline-startup /usr/bin/
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fac20c9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,3 @@
+#!/usr/bin/make -f
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/spline-startup.default b/debian/spline-startup.default
new file mode 100644
index 0000000..e3dea44
--- /dev/null
+++ b/debian/spline-startup.default
@@ -0,0 +1,2 @@
+# Additional arguments that are passed to spline-startup.
+SPLINE_STARTUP_ARGS=""
diff --git a/debian/spline-startup.init b/debian/spline-startup.init
new file mode 100644
index 0000000..97f03fa
--- /dev/null
+++ b/debian/spline-startup.init
@@ -0,0 +1,98 @@
+#!/bin/sh
+### BEGIN INIT INFO
+# Provides: spline-startup
+# Required-Start: $all
+# Required-Stop: $all
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: startup for users
+# Description: <Enter a long description of the software>
+# <...>
+# <...>
+### END INIT INFO
+
+# Author: Alexander Sulfrian <alex@spline.inf.fu-berlin.de>
+PATH=/sbin:/usr/sbin:/bin:/usr/bin
+DESC=spline-startup
+NAME=spline-startup
+SPLINE_STARTUP=/usr/bin/spline-startup
+SPLINE_STARTUP_ARGS=""
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Exit if the package is not installed
+[ -x $DAEMON ] || exit 0
+
+# Read configuration variable file if it is present
+[ -r /etc/default/$NAME ] && . /etc/default/$NAME
+
+. /lib/init/vars.sh
+. /lib/lsb/init-functions
+
+do_action() {
+ action="$1"
+ $SPLINE_STARTUP --syslog $SPLINE_STARTUP_ARGS "$action"
+}
+
+do_start() {
+ do_action "start"
+}
+
+do_stop() {
+ do_action "stop"
+}
+
+do_reload() {
+ do_action "reload"
+}
+
+case "$1" in
+ start)
+ [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC " "$NAME"
+ do_start
+ case "$?" in
+ 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
+ 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
+ esac
+ ;;
+
+ stop)
+ [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
+ do_stop
+ case "$?" in
+ 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
+ 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
+ esac
+ ;;
+
+ reload|force-reload)
+ log_daemon_msg "Reloading $DESC" "$NAME"
+ do_reload
+ log_end_msg $?
+ ;;
+
+ restart)
+ log_daemon_msg "Restarting $DESC" "$NAME"
+ do_stop
+ case "$?" in
+ 0|1)
+ do_start
+ case "$?" in
+ 0) log_end_msg 0 ;;
+ 1) log_end_msg 1 ;; # Old process is still running
+ *) log_end_msg 1 ;; # Failed to start
+ esac
+ ;;
+ *)
+ # Failed to stop
+ log_end_msg 1
+ ;;
+ esac
+ ;;
+
+ *)
+ echo "Usage: $SCRIPTNAME {start|stop|restart|reload|force-reload}" >&2
+ exit 3
+ ;;
+esac
+
+: