summaryrefslogtreecommitdiffstats
path: root/packages/markdown/marked/Makefile
diff options
context:
space:
mode:
authorLauri Ojansivu <x@xet7.org>2019-04-20 16:51:57 +0300
committerLauri Ojansivu <x@xet7.org>2019-04-20 16:51:57 +0300
commit02819ca16969b103493ebdd9a66f058995421507 (patch)
treea3352b65083c79ab733db2b99e7c4f0a1276277e /packages/markdown/marked/Makefile
parent53d42a17ffbc6466d2d422dfdcbd867ea31fe082 (diff)
parenta5122cc0764b57a163c3e8ca3e00e703669a98db (diff)
downloadwekan-02819ca16969b103493ebdd9a66f058995421507.tar.gz
wekan-02819ca16969b103493ebdd9a66f058995421507.tar.bz2
wekan-02819ca16969b103493ebdd9a66f058995421507.zip
Merge branch 'edge' into meteor-1.8
Diffstat (limited to 'packages/markdown/marked/Makefile')
-rw-r--r--packages/markdown/marked/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/markdown/marked/Makefile b/packages/markdown/marked/Makefile
new file mode 100644
index 00000000..7deead54
--- /dev/null
+++ b/packages/markdown/marked/Makefile
@@ -0,0 +1,15 @@
+all:
+ @cp lib/marked.js marked.js
+ @uglifyjs --comments '/\*[^\0]+?Copyright[^\0]+?\*/' -o marked.min.js lib/marked.js
+
+clean:
+ @rm marked.js
+ @rm marked.min.js
+
+bench:
+ @node test --bench
+
+man/marked.1.txt:
+ groff -man -Tascii man/marked.1 | col -b > man/marked.1.txt
+
+.PHONY: clean all