summaryrefslogtreecommitdiffstats
path: root/c-layman/configure.ac
diff options
context:
space:
mode:
authordol-sen <brian.dolbec@gmail.com>2011-10-26 16:19:06 -0700
committerdol-sen <brian.dolbec@gmail.com>2011-10-26 16:19:06 -0700
commitc40874bd95d1525961692dd7d742ed565a2b4334 (patch)
treed774c213a57cb2ed06d74d664a86ccbad4bf4a5b /c-layman/configure.ac
parent9a74747e60f08a6f303d36d45ad9bb2ba828af42 (diff)
parentbce27850d7e2d86e1b8046be8eb1d51c83dbdd2c (diff)
downloadlayman-c40874bd95d1525961692dd7d742ed565a2b4334.tar.gz
layman-c40874bd95d1525961692dd7d742ed565a2b4334.tar.bz2
layman-c40874bd95d1525961692dd7d742ed565a2b4334.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/layman
Diffstat (limited to 'c-layman/configure.ac')
-rw-r--r--c-layman/configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/c-layman/configure.ac b/c-layman/configure.ac
new file mode 100644
index 0000000..9f1d972
--- /dev/null
+++ b/c-layman/configure.ac
@@ -0,0 +1,26 @@
+AC_INIT()
+
+AC_PROG_CC
+
+PACKAGE=layman
+VERSION=0.1
+
+AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+
+LT_INIT([disable-static])
+
+# Get Python 2.6 library and include locations
+AC_ARG_WITH([python-include-path],
+ [AS_HELP_STRING([--with-python-include-path],
+ [location of the Python 2.6 headers, defaults to /usr/include/python2.6])],
+ [PYTHON_CFLAGS="-I$withval"],
+ [PYTHON_CFLAGS='-I/usr/include/python2.6'])
+AC_SUBST([PYTHON_CFLAGS])
+
+AC_ARG_WITH([python-lib-path],
+ [AS_HELP_STRING([--with-python-lib-path], [location of the Python 2.6 library])],
+ [PYTHON_LIBS="-L$withval -lpython2.6"],
+ [PYTHON_LIBS='-lpython2.6'])
+AC_SUBST([PYTHON_LIBS])
+
+AC_OUTPUT(Makefile src/Makefile)