summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..fcb2823
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python
+from distutils.core import setup, Extension
+
+m2crypto_ext_module = Extension(
+ '_M2Crypto_ext',
+ sources=['M2Crypto_ext.i'],
+ swig_opts=['-I/usr/include'],
+ libraries=['ssl']
+)
+
+setup(
+ name = 'M2Crypto_ext',
+ version = '0.1.0',
+ author = "Alexander Sulfrian",
+ description = """Simple swig example from docs""",
+ ext_modules = [m2crypto_ext_module],
+ py_modules = ["M2Crypto_ext"],
+)