summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlrich Mueller <ulm@gentoo.org>2011-05-01 08:57:33 -0700
committerZac Medico <zmedico@gentoo.org>2011-05-04 12:49:15 -0700
commit0256a96fc5be3f3ed303d2993bd7fd9b75ec8ecf (patch)
treebab5b122226775b052901bc39fbabce489a59de5
parentd78d81084de5fe974ecebf64a7080914428f5afc (diff)
downloadportage-0256a96fc5be3f3ed303d2993bd7fd9b75ec8ecf.tar.gz
portage-0256a96fc5be3f3ed303d2993bd7fd9b75ec8ecf.tar.bz2
portage-0256a96fc5be3f3ed303d2993bd7fd9b75ec8ecf.zip
repoman: Check for PROVIDE.
This will fix bug #365505.
-rwxr-xr-xbin/repoman5
-rw-r--r--man/repoman.13
2 files changed, 8 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index d6c26d6ec..017a27bd2 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -366,6 +366,7 @@ qahelp={
"metadata.bad":"Bad metadata.xml files",
"metadata.warning":"Warnings in metadata.xml files",
"portage.internal":"The ebuild uses an internal Portage function",
+ "virtual.oldstyle":"The ebuild PROVIDEs an old-style virtual (see GLEP 37)",
"virtual.versioned":"PROVIDE contains virtuals with versions",
"virtual.exists":"PROVIDE contains existing package names",
"virtual.unavailable":"PROVIDE contains a virtual which contains no profile default",
@@ -1547,6 +1548,10 @@ for x in scanlist:
stats["virtual.exists"]+=1
fails["virtual.exists"].append(x+"/"+y+".ebuild: "+prov_cp)
+ if myaux.get("PROVIDE"):
+ stats["virtual.oldstyle"]+=1
+ fails["virtual.oldstyle"].append(relative_path)
+
for pos, missing_var in enumerate(missingvars):
if not myaux.get(missing_var):
if catdir == "virtual" and \
diff --git a/man/repoman.1 b/man/repoman.1
index 162b62b45..7c3402448 100644
--- a/man/repoman.1
+++ b/man/repoman.1
@@ -353,6 +353,9 @@ Ebuild uses D, ROOT, ED, EROOT or EPREFIX with helpers
.B virtual.exists
PROVIDE contains existing package names
.TP
+.B virtual.oldstyle
+The ebuild PROVIDEs an old-style virtual (see GLEP 37)
+.TP
.B virtual.unavailable
PROVIDE contains a virtual which contains no profile default
.TP