summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-03-23 02:22:21 +0000
committerZac Medico <zmedico@gentoo.org>2009-03-23 02:22:21 +0000
commit69b0b9cef6c065223e473261a04fd4f215df303f (patch)
tree7a8210d4a19820097561369912e8378f4589275b
parentfbe666d80666790e6f71121e274f44ae92dcb12d (diff)
downloadportage-69b0b9cef6c065223e473261a04fd4f215df303f.tar.gz
portage-69b0b9cef6c065223e473261a04fd4f215df303f.tar.bz2
portage-69b0b9cef6c065223e473261a04fd4f215df303f.zip
Use a separate if/then to group boolean or'd expressions together, rather
than a subshell. (trunk r13149) svn path=/main/branches/2.1.6/; revision=13166
-rwxr-xr-xbin/ebuild.sh12
1 files changed, 6 insertions, 6 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index f548a8f05..79db02cf3 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1862,12 +1862,11 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm depend && \
unset PORTAGE_SANDBOX_ON
fi
-if ! hasq "$EBUILD_PHASE" clean cleanrm && \
- (
- hasq ${EBUILD_PHASE} depend || \
- [[ ! -f $T/environment || -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
- hasq noauto ${FEATURES}
- ) ; then
+if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
+if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
+ -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
+ hasq noauto $FEATURES ; then
+
# The bashrcs get an opportunity here to set aliases that will be expanded
# during sourcing of ebuilds and eclasses.
source_all_bashrcs
@@ -1907,6 +1906,7 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm && \
# This needs to be exported since prepstrip is a separate shell script.
[[ -n $QA_PRESTRIPPED ]] && export QA_PRESTRIPPED
fi
+fi
# Set default EAPI if necessary, so that most
# code can simply assume that it's defined.