summaryrefslogtreecommitdiffstats
path: root/bin/ebuild.sh
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-03-23 02:22:06 +0000
committerZac Medico <zmedico@gentoo.org>2009-03-23 02:22:06 +0000
commitfbe666d80666790e6f71121e274f44ae92dcb12d (patch)
tree8e768e8f2651f2ba899e1e707839bb7885c4fa0f /bin/ebuild.sh
parent120d3bc398a4df787cc41c4a5d5be7f9f8d93e63 (diff)
downloadportage-fbe666d80666790e6f71121e274f44ae92dcb12d.tar.gz
portage-fbe666d80666790e6f71121e274f44ae92dcb12d.tar.bz2
portage-fbe666d80666790e6f71121e274f44ae92dcb12d.zip
Make ebuild(1) detect ebuild/eclass changes and automatically source the
ebuild atain in this case (even though $T/environment may already exist). This should help avoid confusion by ensuring that the latest changes to the ebuild/eclasses are reflected in the environment. (trunk r13148) svn path=/main/branches/2.1.6/; revision=13165
Diffstat (limited to 'bin/ebuild.sh')
-rwxr-xr-xbin/ebuild.sh6
1 files changed, 4 insertions, 2 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index d426e15a9..f548a8f05 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -714,7 +714,7 @@ dyn_clean() {
fi
if [[ $EMERGE_FROM = binary ]] || ! hasq keepwork $FEATURES; then
- rm -f "$PORTAGE_BUILDDIR"/.{exit_status,logid,unpacked,prepared} \
+ rm -f "$PORTAGE_BUILDDIR"/.{ebuild_changed,exit_status,logid,unpacked,prepared} \
"$PORTAGE_BUILDDIR"/.{configured,compiled,tested,packaged}
rm -rf "${PORTAGE_BUILDDIR}/build-info"
@@ -1865,7 +1865,7 @@ fi
if ! hasq "$EBUILD_PHASE" clean cleanrm && \
(
hasq ${EBUILD_PHASE} depend || \
- [ ! -f "${T}"/environment ] || \
+ [[ ! -f $T/environment || -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
hasq noauto ${FEATURES}
) ; then
# The bashrcs get an opportunity here to set aliases that will be expanded
@@ -1881,6 +1881,8 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm && \
if [ "${EBUILD_PHASE}" != "depend" ] ; then
RESTRICT=${PORTAGE_RESTRICT}
+ [[ -e $PORTAGE_BUILDDIR/.ebuild_changed ]] && \
+ rm "$PORTAGE_BUILDDIR/.ebuild_changed"
fi
# This next line is not the same as export RDEPEND=${RDEPEND:-${DEPEND}}