summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-08-28 03:28:32 +0000
committerZac Medico <zmedico@gentoo.org>2007-08-28 03:28:32 +0000
commit4709054e83977e49b6aae0120f0553ede08a640c (patch)
tree2395c84d6491db61c6d1b988cbc0e8d6eb77a73b /bin/repoman
parentdfa7289014b7a015f42c4cfc304904488bbc50b1 (diff)
downloadportage-4709054e83977e49b6aae0120f0553ede08a640c.tar.gz
portage-4709054e83977e49b6aae0120f0553ede08a640c.tar.bz2
portage-4709054e83977e49b6aae0120f0553ede08a640c.zip
Skip the most expensive QA tests when --force in enabled since there's no point in wasting time on them when the user is intent on forcing the commit anyway.
svn path=/main/trunk/; revision=7713
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman6
1 files changed, 6 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index 3c68088b3..a9540f534 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1249,6 +1249,12 @@ for x in scanlist:
stats["usage.obsolete"] += 1
fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
+ if "--force" in myoptions:
+ # The dep_check() calls are the most expensive QA test. If --force
+ # is enabled, there's no point in wasting time on these since the
+ # user is intent on forcing the commit anyway.
+ continue
+
for keyword,arch,groups in arches:
if not profiles.has_key(arch):