summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-09-12 03:22:05 +1000
committerZac Medico <zmedico@gentoo.org>2012-09-11 10:46:57 -0700
commit9f735963c000f0e925b513c5378b2552476c0e8e (patch)
tree341feefb6961ae64ef2e5582c2b0b291459f0372 /bin/repoman
parentc512c31e3ce0f53ac3ad4d59a577503413704174 (diff)
downloadportage-9f735963c000f0e925b513c5378b2552476c0e8e.tar.gz
portage-9f735963c000f0e925b513c5378b2552476c0e8e.tar.bz2
portage-9f735963c000f0e925b513c5378b2552476c0e8e.zip
Only validate .desktop files that are installed into XDG-compliant locations.
This replaces the existing error blacklist, and therefore removes the repoman check.
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman24
1 files changed, 0 insertions, 24 deletions
diff --git a/bin/repoman b/bin/repoman
index 53d138c8d..bc2ac9be6 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -78,7 +78,6 @@ from portage.output import bold, create_color_func, \
green, nocolor, red
from portage.output import ConsoleStyleFile, StyleWriter
from portage.util import writemsg_level
-from portage.util._desktop_entry import validate_desktop_entry
from portage.package.ebuild.digestgen import digestgen
from portage.eapi import eapi_has_iuse_defaults, eapi_has_required_use
@@ -303,7 +302,6 @@ def ParseArgs(argv, qahelp):
qahelp={
"CVS/Entries.IO_error":"Attempting to commit, and an IO error was encountered access the Entries file",
- "desktop.invalid":"desktop-file-validate reports errors in a *.desktop file",
"ebuild.invalidname":"Ebuild files with a non-parseable or syntactically incorrect name (or using 2.1 versioning extensions)",
"ebuild.namenomatch":"Ebuild files that do not have the same name as their parent directory",
"changelog.ebuildadded":"An ebuild was added but the ChangeLog was not modified",
@@ -406,7 +404,6 @@ qawarnings = set((
"digest.unused",
"ebuild.notadded",
"ebuild.nesteddie",
-"desktop.invalid",
"DEPEND.badmasked","RDEPEND.badmasked","PDEPEND.badmasked",
"DEPEND.badindev","RDEPEND.badindev","PDEPEND.badindev",
"DEPEND.badmaskedindev","RDEPEND.badmaskedindev","PDEPEND.badmaskedindev",
@@ -1054,10 +1051,6 @@ dev_keywords = dev_keywords(profiles)
stats={}
fails={}
-# provided by the desktop-file-utils package
-desktop_file_validate = find_binary("desktop-file-validate")
-desktop_pattern = re.compile(r'.*\.desktop$')
-
for x in qacats:
stats[x]=0
fails[x]=[]
@@ -1630,23 +1623,6 @@ for x in effective_scanlist:
stats["file.name"] += 1
fails["file.name"].append("%s/files/%s: char '%s'" % \
(checkdir, y, m.group(0)))
-
- if desktop_file_validate and desktop_pattern.match(y):
- cmd_output = validate_desktop_entry(full_path)
- if cmd_output:
- # Note: in the future we may want to grab the
- # warnings in addition to the errors. We're
- # just doing errors now since we don't want
- # to generate too much noise at first.
- error_re = re.compile(r'.*\s*error:\s*(.*)')
- for line in cmd_output:
- error_match = error_re.match(line)
- if error_match is None:
- continue
- stats["desktop.invalid"] += 1
- fails["desktop.invalid"].append(
- relative_path + ': %s' % error_match.group(1))
-
del mydigests
if check_changelog and "ChangeLog" not in checkdirlist: